Directory traversal vulnerability in the TAP plugin before 1.25 in Jenkins allows remote…
Priority LOW 38CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
Directory traversal vulnerability in the TAP plugin before 1.25 in Jenkins allows remote attackers to read arbitrary files via an unspecified parameter.
Why it matters now
EPSS 0.03005 87th percentileScored 2026-11-07
Fix Fixed org.tap4j:tap (Maven): 1.25
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.tap4j:tap (Maven) | before 1.25 | 1.25 | Patch available | GHSA-24jc-w55j-5p83 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.tap4j:tap (Maven) Vendor— Affected before 1.25 Fixed in 1.25 Patch available GHSA-24jc-w55j-5p83
Remediation
- Fix · GHSA-24jc-w55j-5p83 org.tap4j:tap (Maven) Fixed in 1.25 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-4986
- 2026-10-03 Alias added: GHSA-24jc-w55j-5p83
References
More Jenkins Tap vulnerabilities
- TI-2023-22325 Cross-site scripting in Jenkins TAP Plugin CVSS 3.1MEDIUM 5.4
Sources
- CVE-2016-4986 · CVE Program
- CVE-2016-4986 · NVD
- FIRST EPSS
- GHSA-24jc-w55j-5p83 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences