A HTTP/2 implementation built using any version of the Python priority library prior to…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-399 and the CVSS impact.
Summary
A HTTP/2 implementation built using any version of the Python priority library prior to version 1.2.0 could be targeted by a malicious peer by having that peer assign priority information for every possible HTTP/2 stream ID. The priority tree would happily continue to store the priority information for each stream, and would therefore allocate unbounded amounts of memory. Attempting to actually use a tree like this would also cause extremely high CPU usage to maintain the tree.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | priority (PyPI) | before 1.2.0 | 1.2.0 | Patch available | GHSA-h3q4-6j7f-r24c |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- priority (PyPI) Vendor— Affected before 1.2.0 Fixed in 1.2.0 Patch available GHSA-h3q4-6j7f-r24c
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:python:python_priority_library:1.0.0:*:*:*:*:*:*:* | 1.0.0 | Vulnerable | python-pillow |
| cpe:2.3:a:python:python_priority_library:1.1.0:*:*:*:*:*:*:* | 1.1.0 | Vulnerable | python-pillow |
| cpe:2.3:a:python:python_priority_library:1.1.1:*:*:*:*:*:*:* | 1.1.1 | Vulnerable | python-pillow |
- cpe:2.3:a:python:python_priority_library:1.0.0:*:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·python-pillow
- cpe:2.3:a:python:python_priority_library:1.1.0:*:*:*:*:*:*:* Versions 1.1.0 Vulnerable ·python-pillow
- cpe:2.3:a:python:python_priority_library:1.1.1:*:*:*:*:*:*:* Versions 1.1.1 Vulnerable ·python-pillow
Remediation
- Fix · GHSA-h3q4-6j7f-r24c priority (PyPI) Fixed in 1.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-6580
- 2026-10-03 Alias added: GHSA-h3q4-6j7f-r24c
References
Advisory 2
Other 4
Sources
- CVE-2016-6580 · CVE Program
- CVE-2016-6580 · NVD
- FIRST EPSS
- GHSA-h3q4-6j7f-r24c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences