Apache Ignite before 1.9 allows man-in-the-middle attackers to read arbitrary files via…
Priority LOW 30CWE-611Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-611 and the CVSS impact.
Summary
Apache Ignite before 1.9 allows man-in-the-middle attackers to read arbitrary files via XXE in modified update-notifier documents.
Why it matters now
EPSS 0.01989 80th percentileScored 2026-11-07
Fix Fixed org.apache.ignite:ignite-core (Maven): 1.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.ignite:ignite-core (Maven) | before 1.9 | 1.9 | Patch available | GHSA-8qfc-cvjp-mgpq |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.ignite:ignite-core (Maven) Vendor— Affected before 1.9 Fixed in 1.9 Patch available GHSA-8qfc-cvjp-mgpq
Remediation
- Fix · GHSA-8qfc-cvjp-mgpq org.apache.ignite:ignite-core (Maven) Fixed in 1.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-6805
- 2026-10-03 Alias added: GHSA-8qfc-cvjp-mgpq
References
More Apache Ignite vulnerabilities
- TI-2018-01178 Code injection in Spring Framework KEVCVSS 3.1CRITICAL 9.8
- TI-2024-35239 Apache Ignite: Possible RCE when deserializing incoming messages by the server node CVSS 4.0CRITICAL 9.5
- TI-2018-05795 Deserialization of untrusted data in Apache Ignite CVSS 3.0CRITICAL 9.8
- TI-2018-01199 Deserialization of untrusted data in Apache Ignite CVSS 3.0CRITICAL 9.8
- TI-2020-01886 Missing authorization in Apache Ignite CVSS 3.1CRITICAL 9.1
- TI-2025-31105 Apache Ignite: REST HTTP arbitrary file read vulnerability CVSS 4.0HIGH 8.5
Sources
- CVE-2016-6805 · CVE Program
- CVE-2016-6805 · NVD
- FIRST EPSS
- GHSA-8qfc-cvjp-mgpq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences