The "process-execute" and "process-spawn" procedures did not free memory correctly when…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-400.
Summary
The "process-execute" and "process-spawn" procedures did not free memory correctly when the execve() call failed, resulting in a memory leak. This could be abused by an attacker to cause resource exhaustion or a denial of service. This affects all releases of CHICKEN up to and including 4.11 (it will be fixed in 4.12 and 5.0, which are not yet released).
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2016-6831
- 2026-10-03 Alias added: GHSA-x279-7m5p-wjmv
References
More Chicken vulnerabilities
- TI-2022-22220 egg-compile.scm in CHICKEN 5.x before 5.3.1 allows arbitrary OS command execution during… CVSS 3.1CRITICAL 9.8
- TI-2014-05188 Buffer overflow in CHICKEN 4.9.0 and 4.9.0.1 may allow remote attackers to execute… CVSS 3.1CRITICAL 9.8
- TI-2016-05868 The "process-execute" and "process-spawn" procedures in CHICKEN Scheme used fixed-size… CVSS 3.0CRITICAL 9.8
- TI-2012-05089 Chicken before 4.8.0 is susceptible to algorithmic complexity attacks related to hash table collisions. CVSS 3.1CRITICAL 9.8
- TI-2013-01796 OS command injection vulnerability in the "qs" procedure from the "utils" module in Chicken before 4.9.0. CVSS 3.1HIGH 8.8
- TI-2013-01846 Buffer overflow in chicken CVSS 3.1HIGH 8.8
Sources
- CVE-2016-6831 · CVE Program
- CVE-2016-6831 · NVD
- FIRST EPSS
- GHSA-x279-7m5p-wjmv · GitHub Advisory Database · CC BY 4.0
- CVE-2016-6831 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences