Read the docs
TI-2016-06107 Aliases CVE-2016-7103GHSA-hpcf-8vf9-q4gj

Cross-site scripting (XSS) vulnerability in jQuery UI before 1.12.0 might allow remote…

Priority MEDIUM 50CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Partial Red Hat: 3 fixed, 8 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.

Summary

Cross-site scripting (XSS) vulnerability in jQuery UI before 1.12.0 might allow remote attackers to inject arbitrary web script or HTML via the closeText parameter of the dialog function.

Why it matters now

EPSS 0.29186 98th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial jquery-ui (npm): 1.12.0jquery-ui-rails (RubyGems): 6.0.0+2 more productsRed Hat: 3 advisoriesRed Hat: 3 fixed, 8 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—jquery-ui (npm)before 1.12.01.12.0Patch availableGHSA-hpcf-8vf9-q4gj
—jquery-ui-rails (RubyGems)before 6.0.06.0.0Patch availableGHSA-hpcf-8vf9-q4gj
—org.webjars.npm:jquery-ui (Maven)before 1.12.01.12.0Patch availableGHSA-hpcf-8vf9-q4gj
—jQuery.UI.Combined (NuGet)before 1.12.01.12.0Patch availableGHSA-hpcf-8vf9-q4gj
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • jquery-ui (npm) Vendor— Affected before 1.12.0 Fixed in 1.12.0 Patch available GHSA-hpcf-8vf9-q4gj
  • jquery-ui-rails (RubyGems) Vendor— Affected before 6.0.0 Fixed in 6.0.0 Patch available GHSA-hpcf-8vf9-q4gj
  • org.webjars.npm:jquery-ui (Maven) Vendor— Affected before 1.12.0 Fixed in 1.12.0 Patch available GHSA-hpcf-8vf9-q4gj
  • jQuery.UI.Combined (NuGet) Vendor— Affected before 1.12.0 Fixed in 1.12.0 Patch available GHSA-hpcf-8vf9-q4gj

CPE configurations NVD · 21

CPEVersionsRoleVendor
cpe:2.3:a:jqueryui:jquery_ui:*:*:*:*:*:*:*:*1.10.0 – 1.11.4VulnerableJqueryui
cpe:2.3:a:oracle:application_express:*:*:*:*:*:*:*:*before 19.1VulnerableOracle
cpe:2.3:a:oracle:business_intelligence:12.2.1.3.0:*:*:*:enterprise:*:*:*12.2.1.3.0VulnerableOracle
cpe:2.3:a:oracle:business_intelligence:12.2.1.4.0:*:*:*:enterprise:*:*:*12.2.1.4.0VulnerableOracle
cpe:2.3:a:oracle:hospitality_cruise_fleet_management:9.0.11:*:*:*:*:*:*:*9.0.11VulnerableOracle
cpe:2.3:a:oracle:oss_support_tools:*:*:*:*:*:*:*:*before 2.12.42VulnerableOracle
cpe:2.3:a:oracle:oss_support_tools:2.12.42:*:*:*:*:*:*:*2.12.42VulnerableOracle
cpe:2.3:a:oracle:primavera_unifier:*:*:*:*:*:*:*:*16.0 – 16.2; 17.0 – 17.12.4; 18.0 – 18.8.4VulnerableOracle
cpe:2.3:a:oracle:siebel_ui_framework:*:*:*:*:*:*:*:*up to 21.2VulnerableOracle
cpe:2.3:a:oracle:weblogic_server:10.3.6.0.0:*:*:*:*:*:*:*10.3.6.0.0VulnerableOracle
  • cpe:2.3:a:jqueryui:jquery_ui:*:*:*:*:*:*:*:* Versions 1.10.0 – 1.11.4 Vulnerable ·Jqueryui
  • cpe:2.3:a:oracle:application_express:*:*:*:*:*:*:*:* Versions before 19.1 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:business_intelligence:12.2.1.3.0:*:*:*:enterprise:*:*:* Versions 12.2.1.3.0 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:business_intelligence:12.2.1.4.0:*:*:*:enterprise:*:*:* Versions 12.2.1.4.0 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:hospitality_cruise_fleet_management:9.0.11:*:*:*:*:*:*:* Versions 9.0.11 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:oss_support_tools:*:*:*:*:*:*:*:* Versions before 2.12.42 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:oss_support_tools:2.12.42:*:*:*:*:*:*:* Versions 2.12.42 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:primavera_unifier:*:*:*:*:*:*:*:* Versions 16.0 – 16.2; 17.0 – 17.12.4; 18.0 – 18.8.4 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:siebel_ui_framework:*:*:*:*:*:*:*:* Versions up to 21.2 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:weblogic_server:10.3.6.0.0:*:*:*:*:*:*:* Versions 10.3.6.0.0 Vulnerable ·Oracle
Show 11 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:oracle:weblogic_server:12.1.3.0.0:*:*:*:*:*:*:*12.1.3.0.0VulnerableOracle
cpe:2.3:a:oracle:weblogic_server:12.2.1.3.0:*:*:*:*:*:*:*12.2.1.3.0VulnerableOracle
cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:*30VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:*35VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:*36VulnerableFedoraproject
cpe:2.3:a:netapp:snapcenter:-:*:*:*:*:*:*:*not specified by NVDVulnerableNetApp
cpe:2.3:a:redhat:openstack:7.0:*:*:*:*:*:*:*7.0VulnerableRed Hat
cpe:2.3:a:redhat:openstack:8:*:*:*:*:*:*:*8VulnerableRed Hat
cpe:2.3:a:redhat:openstack:9:*:*:*:*:*:*:*9VulnerableRed Hat
cpe:2.3:o:juniper:junos:21.2:-:*:*:*:*:*:*21.2VulnerableJuniper
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
  • cpe:2.3:a:oracle:weblogic_server:12.1.3.0.0:*:*:*:*:*:*:* Versions 12.1.3.0.0 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:weblogic_server:12.2.1.3.0:*:*:*:*:*:*:* Versions 12.2.1.3.0 Vulnerable ·Oracle
  • cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* Versions 30 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
  • cpe:2.3:a:netapp:snapcenter:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
  • cpe:2.3:a:redhat:openstack:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:openstack:8:*:*:*:*:*:*:* Versions 8 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:openstack:9:*:*:*:*:*:*:* Versions 9 Vulnerable ·Red Hat
  • cpe:2.3:o:juniper:junos:21.2:-:*:*:*:*:*:* Versions 21.2 Vulnerable ·Juniper
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-hpcf-8vf9-q4gj jquery-ui (npm) Fixed in 1.12.0 Advisory →
  • Fix · GHSA-hpcf-8vf9-q4gj jquery-ui-rails (RubyGems) Fixed in 6.0.0 Advisory →
  • Fix · GHSA-hpcf-8vf9-q4gj org.webjars.npm:jquery-ui (Maven) Fixed in 1.12.0 Advisory →
  • Fix · GHSA-hpcf-8vf9-q4gj jQuery.UI.Combined (NuGet) Fixed in 1.12.0 Advisory →

Red Hat 3 advisories

  • RHSA-2017:0161 Released 2017-01-19 · Red Hat rating Low
    python-XStatic-jquery-ui security update
    • Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7 python-XStatic-jquery-ui-1.12.0.1-1.el7ost
  • RHSA-2016:2932 Released 2016-12-08 · Red Hat rating Low
    python-XStatic-jquery-ui security update
    • Red Hat OpenStack Platform 8.0 (Liberty) python-XStatic-jquery-ui-1.12.0.1-1.el7ost
  • RHSA-2016:2933 Released 2016-12-08 · Red Hat rating Low
    python-XStatic-jquery-ui security update
    • Red Hat OpenStack Platform 9.0 python-XStatic-jquery-ui-1.12.0.1-1.el7ost

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

ProductStatusPlan or fix
OpenStack ForemanAffectedNo fix planned: Will not fix
Red Hat Decision Manager 7AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux OpenStack Platform 6 (Juno)AffectedNo fix planned: Will not fix
Red Hat Enterprise Linux OpenStack Platform 6 (Juno) InstallerAffectedNo fix planned: Will not fix
Red Hat OpenStack Platform 10 (Newton)AffectedNo fix yet
Red Hat Process Automation 7AffectedNo fix planned: Out of support scope
Red Hat Satellite 5AffectedNo fix yet
Red Hat Satellite 6AffectedNo fix yet
Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7Fixed RHSA-2017:0161
Red Hat OpenStack Platform 8.0 (Liberty)Fixed RHSA-2016:2932
Red Hat OpenStack Platform 9.0Fixed RHSA-2016:2933

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-7103
  2. 2026-10-03 Alias added: GHSA-hpcf-8vf9-q4gj

References

Other 18

Sources