Read the docs
TI-2016-06112 Aliases CVE-2016-7111GHSA-8vx9-hcvq-gfv8

MantisBT before 1.3.1 and 2.x before 2.0.0-beta.2 uses a weak Content Security Policy…

Priority LOW 24CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
High
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

MantisBT before 1.3.1 and 2.x before 2.0.0-beta.2 uses a weak Content Security Policy when using the Gravatar plugin, which allows remote attackers to conduct cross-site scripting (XSS) attacks via unspecified vectors.

Why it matters now

EPSS 0.01003 63rd percentileScored 2026-11-07
Fix Fixed mantisbt/mantisbt (Packagist): 1.3.1, 2.0.0-beta.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—mantisbt/mantisbt (Packagist)before 1.3.11.3.1Patch availableGHSA-8vx9-hcvq-gfv8
—mantisbt/mantisbt (Packagist)2.0.0-beta.1 to before 2.0.0-beta.22.0.0-beta.2Patch availableGHSA-8vx9-hcvq-gfv8
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • mantisbt/mantisbt (Packagist) Vendor— Affected before 1.3.1 Fixed in 1.3.1 Patch available GHSA-8vx9-hcvq-gfv8
  • mantisbt/mantisbt (Packagist) Vendor— Affected 2.0.0-beta.1 to before 2.0.0-beta.2 Fixed in 2.0.0-beta.2 Patch available GHSA-8vx9-hcvq-gfv8

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:mantisbt:mantisbt:*:*:*:*:*:*:*:*up to 1.3.0Vulnerablemantisbt
cpe:2.3:a:mantisbt:mantisbt:2.0.0:beta1:*:*:*:*:*:*2.0.0 beta1Vulnerablemantisbt
  • cpe:2.3:a:mantisbt:mantisbt:*:*:*:*:*:*:*:* Versions up to 1.3.0 Vulnerable ·mantisbt
  • cpe:2.3:a:mantisbt:mantisbt:2.0.0:beta1:*:*:*:*:*:* Versions 2.0.0 beta1 Vulnerable ·mantisbt

Remediation

  • Fix · GHSA-8vx9-hcvq-gfv8 mantisbt/mantisbt (Packagist) Fixed in 1.3.1 Advisory →
  • Fix · GHSA-8vx9-hcvq-gfv8 mantisbt/mantisbt (Packagist) Fixed in 2.0.0-beta.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-7111
  2. 2026-10-03 Alias added: GHSA-8vx9-hcvq-gfv8

References

  • TI-2017-05251 MantisBT through 2.3.0 allows arbitrary password reset and unauthenticated admin access… CVSS 3.1HIGH 8.8
  • TI-2014-05966 The XmlImportExport plugin in MantisBT 1.2.17 and earlier allows remote attackers to… CVSS 2.0HIGH 7.5
  • TI-2025-38760 MantisBT unauthorized disclosure of private project column configuration CVSS 4.0MEDIUM 5.3
  • TI-2017-04981 A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page… CVSS 3.0MEDIUM 4.8
  • TI-2019-11797 MantisBT before 1.3.20 and 2.22.1 allows Post Authentication Command Injection, leading to Remote Code Execution. CVSS 3.1HIGH 7.2
  • TI-2014-07063 The XML Import/Export plugin in MantisBT 1.2.x does not restrict access, which allows… CVSS 2.0MEDIUM 6.4
See all 121 →

Sources