The Chakra JavaScript scripting engine in Microsoft Edge allows remote attackers to…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-843 and the CVSS impact.
Summary
The Chakra JavaScript scripting engine in Microsoft Edge allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, aka "Scripting Engine Memory Corruption Vulnerability," a different vulnerability than CVE-2016-7200, CVE-2016-7202, CVE-2016-7203, CVE-2016-7208, CVE-2016-7240, CVE-2016-7242, and CVE-2016-7243.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Microsoft.ChakraCore (NuGet) | before 1.2.2 | 1.2.2 | Patch available | GHSA-4f5g-j7wg-7w8j |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Microsoft.ChakraCore (NuGet) Vendor— Affected before 1.2.2 Fixed in 1.2.2 Patch available GHSA-4f5g-j7wg-7w8j
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:microsoft:edge:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | Microsoft |
| cpe:2.3:o:microsoft:windows_10_1507:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
| cpe:2.3:o:microsoft:windows_10_1511:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
| cpe:2.3:o:microsoft:windows_10_1607:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
| cpe:2.3:o:microsoft:windows_server_2016:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
- cpe:2.3:a:microsoft:edge:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Microsoft
- cpe:2.3:o:microsoft:windows_10_1507:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
- cpe:2.3:o:microsoft:windows_10_1511:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
- cpe:2.3:o:microsoft:windows_10_1607:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
- cpe:2.3:o:microsoft:windows_server_2016:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
Remediation
- Fix · GHSA-4f5g-j7wg-7w8j Microsoft.ChakraCore (NuGet) Fixed in 1.2.2 Advisory →
Timeline
- 2022-03-28 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2016-7201
- 2026-10-03 Alias added: GHSA-4f5g-j7wg-7w8j
References
Patch 1
Advisory 2
Other 8
- https://github.com/chakra-core/ChakraCore/pull/1982
- https://github.com/chakra-core/ChakraCore/commit/c2787ef8fdb7401922e9ec6540e4e5895d11c631
- https://github.com/chakra-core/ChakraCore
- https://web.archive.org/web/20210123185125/http://www.securityfocus.com/bid/94038
- https://web.archive.org/web/20211126224744/http://www.securitytracker.com/id/1037245
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2016-7201
- https://www.exploit-db.com/exploits/40784
- https://www.exploit-db.com/exploits/40990
More Microsoft Edge vulnerabilities
- TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2022-03781 Out-of-bounds write in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2015-00277 Use-after-free vulnerability in Adobe Flash Player before 13.0.0.269 and 14.x through… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-00275 Unspecified vulnerability in Adobe Flash Player through 13.0.0.262 and 14.x, 15.x, and… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-04799 Out-of-bounds write in Google Chrome KEVCVSS 3.1HIGH 8.8
- TI-2020-12621 Out-of-bounds write in Google Chrome KEVCVSS 3.1HIGH 8.8
Sources
- CVE-2016-7201 · CVE Program
- CVE-2016-7201 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-4f5g-j7wg-7w8j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences