Read the docs
TI-2016-06303 Aliases CVE-2016-7401GHSA-crhm-qpjc-cm64

The cookie parsing code in Django before 1.8.15 and 1.9.x before 1.9.10, when used on a…

Priority MEDIUM 41CWE-254Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Partial Red Hat: 6 fixed, 3 without a fix

Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.

Summary

The cookie parsing code in Django before 1.8.15 and 1.9.x before 1.9.10, when used on a site with Google Analytics, allows remote attackers to bypass an intended CSRF protection mechanism by setting arbitrary cookies.

Why it matters now

EPSS 0.05702 93rd percentileScored 2026-11-07
Fix Partial Django (PyPI): 1.8.15, 1.9.10Red Hat: 6 advisoriesRed Hat: 6 fixed, 3 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—Django (PyPI)before 1.8.151.8.15Patch availableGHSA-crhm-qpjc-cm64
—Django (PyPI)1.9 to before 1.9.101.9.10Patch availableGHSA-crhm-qpjc-cm64
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • Django (PyPI) Vendor— Affected before 1.8.15 Fixed in 1.8.15 Patch available GHSA-crhm-qpjc-cm64
  • Django (PyPI) Vendor— Affected 1.9 to before 1.9.10 Fixed in 1.9.10 Patch available GHSA-crhm-qpjc-cm64

CPE configurations NVD · 15

CPEVersionsRoleVendor
cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:*12.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:*14.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:*16.04VulnerableCanonical
cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:*up to 1.8.14Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.9.0:*:*:*:*:*:*:*1.9.0Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.9.1:*:*:*:*:*:*:*1.9.1Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.9.2:*:*:*:*:*:*:*1.9.2Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.9.3:*:*:*:*:*:*:*1.9.3Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.9.4:*:*:*:*:*:*:*1.9.4Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.9.5:*:*:*:*:*:*:*1.9.5Vulnerabledjangoproject
  • cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:* Versions 12.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
  • cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions up to 1.8.14 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.9.0:*:*:*:*:*:*:* Versions 1.9.0 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.9.1:*:*:*:*:*:*:* Versions 1.9.1 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.9.2:*:*:*:*:*:*:* Versions 1.9.2 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.9.3:*:*:*:*:*:*:* Versions 1.9.3 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.9.4:*:*:*:*:*:*:* Versions 1.9.4 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.9.5:*:*:*:*:*:*:* Versions 1.9.5 Vulnerable ·djangoproject
Show 5 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:djangoproject:django:1.9.6:*:*:*:*:*:*:*1.9.6Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.9.7:*:*:*:*:*:*:*1.9.7Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.9.8:*:*:*:*:*:*:*1.9.8Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.9.9:*:*:*:*:*:*:*1.9.9Vulnerabledjangoproject
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
  • cpe:2.3:a:djangoproject:django:1.9.6:*:*:*:*:*:*:* Versions 1.9.6 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.9.7:*:*:*:*:*:*:* Versions 1.9.7 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.9.8:*:*:*:*:*:*:* Versions 1.9.8 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.9.9:*:*:*:*:*:*:* Versions 1.9.9 Vulnerable ·djangoproject
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-crhm-qpjc-cm64 Django (PyPI) Fixed in 1.8.15 Advisory →
  • Fix · GHSA-crhm-qpjc-cm64 Django (PyPI) Fixed in 1.9.10 Advisory →

Red Hat 6 advisories

  • RHSA-2016:2040 Released 2016-10-10 · Red Hat rating Moderate
    python-django security update
    • Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7 python-django-1.6.11-6.el7ost, python-django-bash-completion-1.6.11-6.el7ost, python-django-doc-1.6.11-6.el7ost
  • RHSA-2016:2041 Released 2016-10-10 · Red Hat rating Moderate
    python-django security update
    • Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7 python-django-1.8.15-1.el7ost, python-django-bash-completion-1.8.15-1.el7ost, python-django-doc-1.8.15-1.el7ost
  • RHSA-2016:2038 Released 2016-10-10 · Red Hat rating Moderate
    python-django security update
    • Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6 python-django-1.6.11-6.el6ost, python-django-bash-completion-1.6.11-6.el6ost, python-django-doc-1.6.11-6.el6ost
Show 3 more Red Hat advisories
  • RHSA-2016:2039 Released 2016-10-10 · Red Hat rating Moderate
    python-django security update
    • Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7 python-django-1.6.11-6.el7ost, python-django-bash-completion-1.6.11-6.el7ost, python-django-doc-1.6.11-6.el7ost
  • RHSA-2016:2042 Released 2016-10-10 · Red Hat rating Moderate
    python-django security update
    • Red Hat OpenStack Platform 8.0 (Liberty) python-django-1.8.15-1.el7ost, python-django-bash-completion-1.8.15-1.el7ost
  • RHSA-2016:2043 Released 2016-10-10 · Red Hat rating Moderate
    python-django security update
    • Red Hat OpenStack Platform 9.0 python-django-1.8.15-1.el7ost, python-django-bash-completion-1.8.15-1.el7ost

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux OpenStack Platform 7 (Kilo) Operational ToolsAffectedNo fix planned: Will not fix
Red Hat OpenStack Platform 8 (Liberty) Operational ToolsAffectedNo fix planned: Will not fix
Red Hat OpenStack Platform 9 (Mitaka) Operational ToolsAffectedNo fix planned: Will not fix
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6Fixed RHSA-2016:2038
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7Fixed RHSA-2016:2039
Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7Fixed RHSA-2016:2040
Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7Fixed RHSA-2016:2041
Red Hat OpenStack Platform 8.0 (Liberty)Fixed RHSA-2016:2042
Red Hat OpenStack Platform 9.0Fixed RHSA-2016:2043
Not affected: 5 products
  • Red Hat Ceph Storage 1.3
  • Red Hat Ceph Storage 2
  • Red Hat OpenStack Platform 10 (Newton)
  • Red Hat OpenStack Platform 10 (Newton) Operational Tools
  • Red Hat Subscription Asset Manager

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-7401
  2. 2026-10-03 Alias added: GHSA-crhm-qpjc-cm64

References

Sources