SQL injection in https://github.com/geopython pycsw
Priority MEDIUM 44CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
A SQL injection vulnerability in pycsw all versions before 2.0.2, 1.10.5 and 1.8.6 that leads to read and extract of any data from any table in the pycsw database that the database user has access to. Also on PostgreSQL (at least) it is possible to perform updates/inserts/deletes and database modifications to any table the database user has access to.
Why it matters now
EPSS 0.02306 83rd percentileScored 2026-11-07
Fix Fixed pycsw (PyPI): 2.0.2, 1.8.6, 1.10.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| https://github.com/geopython | pycsw | all versions before 2.0.2, 1.10.5 and 1.8.6 | — | No fix listed | CNA |
| — | pycsw (PyPI) | 2.0.0 to before 2.0.2 | 2.0.2 | Patch available | GHSA-hg4c-rgvm-964g |
| — | pycsw (PyPI) | before 1.8.6 | 1.8.6 | Patch available | GHSA-hg4c-rgvm-964g |
| — | pycsw (PyPI) | 1.10.0 to before 1.10.5 | 1.10.5 | Patch available | GHSA-hg4c-rgvm-964g |
- pycsw Vendorhttps://github.com/geopython Affected all versions before 2.0.2, 1.10.5 and 1.8.6 Fixed in — No fix listed CNA
- pycsw (PyPI) Vendor— Affected 2.0.0 to before 2.0.2 Fixed in 2.0.2 Patch available GHSA-hg4c-rgvm-964g
- pycsw (PyPI) Vendor— Affected before 1.8.6 Fixed in 1.8.6 Patch available GHSA-hg4c-rgvm-964g
- pycsw (PyPI) Vendor— Affected 1.10.0 to before 1.10.5 Fixed in 1.10.5 Patch available GHSA-hg4c-rgvm-964g
Remediation
- Fix · GHSA-hg4c-rgvm-964g pycsw (PyPI) Fixed in 2.0.2 Advisory →
- Fix · GHSA-hg4c-rgvm-964g pycsw (PyPI) Fixed in 1.8.6 Advisory →
- Fix · GHSA-hg4c-rgvm-964g pycsw (PyPI) Fixed in 1.10.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-8640
- 2026-10-03 Alias added: GHSA-hg4c-rgvm-964g
References
Patch 3
Advisory 2
Other 5
- https://github.com/geopython/pycsw/commit/522873e5ce48bb9cbd4e7e8168ca881ce709c222
- https://github.com/geopython/pycsw/commit/69546e13527c82e4f9191769215490381ad511b2
- https://github.com/geopython/pycsw/commit/daaf09b4b920708a415be3c7f446739661ba3753
- https://github.com/geopython/pycsw
- https://github.com/pypa/advisory-database/tree/main/vulns/pycsw/PYSEC-2018-98.yaml
Sources
- CVE-2016-8640 · CVE Program
- CVE-2016-8640 · NVD
- FIRST EPSS
- GHSA-hg4c-rgvm-964g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences