Cross-site scripting in Apache NiFi
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In Apache NiFi before 1.0.1 and 1.1.x before 1.1.1, there is a cross-site scripting vulnerability in connection details dialog when accessed by an authorized user. The user supplied text was not being properly handled when added to the DOM.
Why it matters now
EPSS 0.01994 80th percentileScored 2026-11-07
Fix Fixed org.apache.nifi:nifi (Maven): 1.0.1, 1.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache NiFi | 1.0.0; 1.1.0 | — | No fix listed | CNA |
| — | org.apache.nifi:nifi (Maven) | before 1.0.1 | 1.0.1 | Patch available | GHSA-g2fm-x3cp-mqw9 |
| — | org.apache.nifi:nifi (Maven) | 1.1.0 to before 1.1.1 | 1.1.1 | Patch available | GHSA-g2fm-x3cp-mqw9 |
- Apache NiFi VendorApache Affected 1.0.0; 1.1.0 Fixed in — No fix listed CNA
- org.apache.nifi:nifi (Maven) Vendor— Affected before 1.0.1 Fixed in 1.0.1 Patch available GHSA-g2fm-x3cp-mqw9
- org.apache.nifi:nifi (Maven) Vendor— Affected 1.1.0 to before 1.1.1 Fixed in 1.1.1 Patch available GHSA-g2fm-x3cp-mqw9
Remediation
- Fix · GHSA-g2fm-x3cp-mqw9 org.apache.nifi:nifi (Maven) Fixed in 1.0.1 Advisory →
- Fix · GHSA-g2fm-x3cp-mqw9 org.apache.nifi:nifi (Maven) Fixed in 1.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-8748
- 2026-10-03 Alias added: GHSA-g2fm-x3cp-mqw9
References
More Apache Nifi vulnerabilities
- TI-2023-17293 Apache NiFi: Potential Code Injection with Database Services using H2 CVSS 3.1HIGH 8.8
- TI-2020-16549 Uncontrolled resource consumption in Eclipse Jetty CVSS 3.1MEDIUM 5.3
- TI-2019-07411 Deserialization of untrusted data in Apache Commons Beanutils CVSS 3.1HIGH 7.3
- TI-2017-11471 Improper input validation in Apache NiFi CVSS 3.0CRITICAL 9.8
- TI-2018-01212 XML external entity injection in Apache NiFi CVSS 3.0CRITICAL 9.8
- TI-2021-03489 Deserialization of untrusted data in jackson-databind CVSS 3.1HIGH 8.1
Sources
- CVE-2016-8748 · CVE Program
- CVE-2016-8748 · NVD
- FIRST EPSS
- GHSA-g2fm-x3cp-mqw9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences