Versions 1.17 and 1.18 of the Python urllib3 library suffer from a vulnerability that can…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-295.
Summary
Versions 1.17 and 1.18 of the Python urllib3 library suffer from a vulnerability that can cause them, in certain configurations, to not correctly validate TLS certificates. This places users of the library with those configurations at risk of man-in-the-middle and information leakage attacks. This vulnerability affects users using versions 1.17 and 1.18 of the urllib3 library, who are using the optional PyOpenSSL support for TLS instead of the regular standard library TLS backend, and who are using OpenSSL 1.1.0 via PyOpenSSL. This is an extremely uncommon configuration, so the security impact of this vulnerability is low.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | urllib3 (PyPI) | 1.17 to before 1.18.1 | 1.18.1 | Patch available | GHSA-v4w5-p2hg-8fh6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- urllib3 (PyPI) Vendor— Affected 1.17 to before 1.18.1 Fixed in 1.18.1 Patch available GHSA-v4w5-p2hg-8fh6
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:python:urllib3:1.17:*:*:*:*:*:*:* | 1.17 | Vulnerable | python-pillow |
| cpe:2.3:a:python:urllib3:1.18:*:*:*:*:*:*:* | 1.18 | Vulnerable | python-pillow |
- cpe:2.3:a:python:urllib3:1.17:*:*:*:*:*:*:* Versions 1.17 Vulnerable ·python-pillow
- cpe:2.3:a:python:urllib3:1.18:*:*:*:*:*:*:* Versions 1.18 Vulnerable ·python-pillow
Remediation
- Fix · GHSA-v4w5-p2hg-8fh6 urllib3 (PyPI) Fixed in 1.18.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-9015
- 2026-10-03 Alias added: GHSA-v4w5-p2hg-8fh6
References
Other 5
- [oss-security] 20161027 CVE-2016-9015: Python urllib3 1.17 and 1.18 certificate verification failure
- https://github.com/urllib3/urllib3/commit/c32cdbc16a9634fa0f8c829d1270301570158715
- https://github.com/pypa/advisory-database/tree/main/vulns/urllib3/PYSEC-2017-98.yaml
- https://github.com/urllib3/urllib3
- https://web.archive.org/web/20210123184150/http://www.securityfocus.com/bid/93941
More python-pillow Urllib3 vulnerabilities
- TI-2026-17326 urllib3 vulnerable to decompression-bomb safeguard bypass when following HTTP redirects (streaming API) CVSS 4.0HIGH 8.9
- TI-2018-14221 urllib3 before version 1.23 does not remove the Authorization HTTP header when following… CVSS 3.0CRITICAL 9.8
- TI-2025-40854 urllib3 allows an unbounded number of links in the decompression chain CVSS 4.0HIGH 8.9
- TI-2026-32373 urllib3: Decompression-bomb safeguards bypassed in parts of the streaming API CVSS 4.0HIGH 8.9
- TI-2025-40898 urllib3 Streaming API improperly handles highly compressed data CVSS 4.0HIGH 8.9
- TI-2021-12905 An issue was discovered in urllib3 before 1.26.5. CVSS 3.1HIGH 7.5
Sources
- CVE-2016-9015 · CVE Program
- CVE-2016-9015 · NVD
- FIRST EPSS
- GHSA-v4w5-p2hg-8fh6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences