Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin…
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.8 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Why it matters now
EPSS 0.01452 73rd percentileScored 2026-11-07
Fix Fixed moin (PyPI): 1.9.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moin (PyPI) | before 1.9.8 | 1.9.8 | Patch available | GHSA-5fq5-pfv8-mrfv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moin (PyPI) Vendor— Affected before 1.9.8 Fixed in 1.9.8 Patch available GHSA-5fq5-pfv8-mrfv
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moinmo:moinmoin:*:*:*:*:*:*:*:* | up to 1.9.7 | Vulnerable | Moinmo |
| cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:* | 12.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:16.10:*:*:*:*:*:*:* | 16.10 | Vulnerable | Canonical |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:moinmo:moinmoin:*:*:*:*:*:*:*:* Versions up to 1.9.7 Vulnerable ·Moinmo
- cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:* Versions 12.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:16.10:*:*:*:*:*:*:* Versions 16.10 Vulnerable ·Canonical
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-5fq5-pfv8-mrfv moin (PyPI) Fixed in 1.9.8 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2016-9119
- 2026-10-03 Alias added: GHSA-5fq5-pfv8-mrfv
References
Advisory 4
Sources
- CVE-2016-9119 · CVE Program
- CVE-2016-9119 · NVD
- FIRST EPSS
- GHSA-5fq5-pfv8-mrfv · GitHub Advisory Database · CC BY 4.0
- CVE-2016-9119 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences