Pillow before 3.3.2 allows context-dependent attackers to obtain sensitive information by…
Priority LOW 29CWE-190Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Pillow before 3.3.2 allows context-dependent attackers to obtain sensitive information by using the "crafted image file" approach, related to an "Integer Overflow" issue affecting the Image.core.map_buffer in map.c component.
Why it matters now
EPSS 0.01945 80th percentileScored 2026-11-07
Fix Partial pillow (PyPI): 3.3.2Red Hat: 3 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pillow (PyPI) | before 3.3.2 | 3.3.2 | Patch available | GHSA-rwr3-c2q8-gm56 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pillow (PyPI) Vendor— Affected before 3.3.2 Fixed in 3.3.2 Patch available GHSA-rwr3-c2q8-gm56
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:python:pillow:*:*:*:*:*:*:*:* | up to 3.3.1 | Vulnerable | python-pillow |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:python:pillow:*:*:*:*:*:*:*:* Versions up to 3.3.1 Vulnerable ·python-pillow
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-rwr3-c2q8-gm56 pillow (PyPI) Fixed in 3.3.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2016-9189
- 2026-10-03 Alias added: GHSA-rwr3-c2q8-gm56
References
Patch 2
Advisory 5
Sources
- CVE-2016-9189 · CVE Program
- CVE-2016-9189 · NVD
- FIRST EPSS
- GHSA-rwr3-c2q8-gm56 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-9189 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences