Improper input validation in Ansible
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 7 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed by Ansible and the ability to send facts back to the Ansible server could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| unspecified | Ansible | ansible 2.1.4; ansible 2.2.1 | — | No fix listed | CNA |
| — | ansible (PyPI) | before 2.1.4.0 | 2.1.4.0 | Patch available | GHSA-m956-frf4-m2wr |
| — | ansible (PyPI) | 2.2.0.0 to before 2.2.1.0 | 2.2.1.0 | Patch available | GHSA-m956-frf4-m2wr |
- Ansible Vendorunspecified Affected ansible 2.1.4; ansible 2.2.1 Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected before 2.1.4.0 Fixed in 2.1.4.0 Patch available GHSA-m956-frf4-m2wr
- ansible (PyPI) Vendor— Affected 2.2.0.0 to before 2.2.1.0 Fixed in 2.2.1.0 Patch available GHSA-m956-frf4-m2wr
Remediation
- Fix · GHSA-m956-frf4-m2wr ansible (PyPI) Fixed in 2.1.4.0 Advisory →
- Fix · GHSA-m956-frf4-m2wr ansible (PyPI) Fixed in 2.2.1.0 Advisory →
Red Hat 5 advisories
- RHSA-2017:1685 Released 2017-07-06 · Red Hat rating Importantansible security, bug fix, and enhancement update
- Red Hat Virtualization Manager 4.1 ansible-2.3.0.0-4.el7, ansible-doc-2.3.0.0-4.el7
- RHSA-2017:0515 Released 2017-03-14 · Red Hat rating Importantansible and ceph-ansible security, bug fix, and enhancement update
- Red Hat Storage Console Installer 2 ansible-2.2.1.0-1.el7, ceph-ansible-2.1.9-1.el7scon, ceph-installer-1.2.2-1.el7scon +1
- RHSA-2017:0448 Released 2017-03-06 · Red Hat rating Importantansible and openshift-ansible security and bug fix update
- Red Hat OpenShift Container Platform 3.2 ansible-2.2.1.0-2.el7, atomic-openshift-utils-3.2.53-1.git.0.2fefc17.el7, openshift-ansible-3.2.53-1.git.0.2fefc17.el7 +5
- Red Hat OpenShift Container Platform 3.3 ansible-2.2.1.0-2.el7, atomic-openshift-utils-3.3.67-1.git.0.7c5da0c.el7, openshift-ansible-3.3.67-1.git.0.7c5da0c.el7 +6
- Red Hat OpenShift Container Platform 3.4 ansible-2.2.1.0-2.el7, atomic-openshift-utils-3.4.67-1.git.0.14a0b4d.el7, openshift-ansible-3.4.67-1.git.0.14a0b4d.el7 +6
Show 2 more Red Hat advisories
- RHSA-2017:0260 Released 2017-02-07 · Red Hat rating Importantansible and gdeploy security and bug fix update
- Red Hat Gluster Storage Server 3.1 on RHEL-7 ansible-2.2.1.0-2.el7, gdeploy-2.0.1-8.el7rhgs, python-passlib-1.6.5-1.el7 +1
- RHSA-2017:0195 Released 2017-01-25 · Red Hat rating Importantansible security update
- Red Hat OpenStack Platform 10.0 ansible-2.2.1.0-1.el7
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenStack Platform 11 (Ocata) | Affected | No fix yet |
| Red Hat Quickstart Cloud Installer 1 | Affected | No fix planned: Will not fix |
| Red Hat Gluster Storage Server 3.1 on RHEL-7 | Fixed | RHSA-2017:0260 |
| Red Hat OpenShift Container Platform 3.2 | Fixed | RHSA-2017:0448 |
| Red Hat OpenShift Container Platform 3.3 | Fixed | RHSA-2017:0448 |
| Red Hat OpenShift Container Platform 3.4 | Fixed | RHSA-2017:0448 |
| Red Hat OpenStack Platform 10.0 | Fixed | RHSA-2017:0195 |
| Red Hat Storage Console Installer 2 | Fixed | RHSA-2017:0515 |
| Red Hat Virtualization Manager 4.1 | Fixed | RHSA-2017:1685 |
Timeline
- 2026-10-02 Threatist record created from CVE-2016-9587
- 2026-10-03 Alias added: GHSA-m956-frf4-m2wr
References
Exploit 1
Advisory 9
Sources
- CVE-2016-9587 · CVE Program
- CVE-2016-9587 · NVD
- FIRST EPSS
- GHSA-m956-frf4-m2wr · GitHub Advisory Database · CC BY 4.0
- CVE-2016-9587 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences