Code injection in Google Chrome
Priority MEDIUM 51CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-94.
Summary
A missing check for whether a property of a JS object is private in V8 in Google Chrome prior to 55.0.2883.75 allowed a remote attacker to execute arbitrary code inside a sandbox via a crafted HTML page.
Why it matters now
EPSS 0.11182 95th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed Chrome (Google): 55.0.2883.75Red Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Chrome | before 55.0.2883.75 | 55.0.2883.75 | Patch available | CNA |
- Chrome VendorGoogle Affected before 55.0.2883.75 Fixed in 55.0.2883.75 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* | before 55.0.2883.75 | Vulnerable | |
| cpe:2.3:o:redhat:enterprise_linux_desktop:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_workstation:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
- cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* Versions before 55.0.2883.75 Vulnerable ·Google
- cpe:2.3:o:redhat:enterprise_linux_desktop:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_workstation:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
Remediation
- Fix · CNA Chrome (Google) Fixed in 55.0.2883.75
Red Hat 1 advisory
- RHSA-2016:2919 Released 2016-12-07 · Red Hat rating Importantchromium-browser security update
- Red Hat Enterprise Linux Desktop Supplementary (v. 6) chromium-browser-55.0.2883.75-1.el6
- Red Hat Enterprise Linux Server Supplementary (v. 6) chromium-browser-55.0.2883.75-1.el6
- Red Hat Enterprise Linux Workstation Supplementary (v. 6) chromium-browser-55.0.2883.75-1.el6
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux Desktop Supplementary (v. 6) | Fixed | RHSA-2016:2919 |
| Red Hat Enterprise Linux Server Supplementary (v. 6) | Fixed | RHSA-2016:2919 |
| Red Hat Enterprise Linux Workstation Supplementary (v. 6) | Fixed | RHSA-2016:2919 |
Timeline
- 2026-10-02 Threatist record created from CVE-2016-9651
- 2026-10-03 Alias added: GHSA-wp7w-fjvj-wrv2
References
More Google Chrome vulnerabilities
- TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
- TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04898 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04600 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04346 Use after free in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2023-05824 Integer overflow in Google Chrome KEVCVSS 3.1CRITICAL 9.6
Sources
- CVE-2016-9651 · CVE Program
- CVE-2016-9651 · NVD
- FIRST EPSS
- GHSA-wp7w-fjvj-wrv2 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-9651 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences