An error handling certain queries using the nxdomain-redirect feature could cause a REQUIRE assertion failure in db.c
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · CNA. Fix status from CNA.
Summary
An error in handling certain queries can cause an assertion failure when a server is using the nxdomain-redirect feature to cover a zone for which it is also providing authoritative service. A vulnerable server could be intentionally stopped by an attacker if it was using a configuration that met the criteria for the vulnerability and if the attacker could cause it to accept a query that possessed the required attributes. Please note: This vulnerability affects the "nxdomain-redirect" feature, which is one of two methods of handling NXDOMAIN redirection, and is only available in certain versions of BIND. Redirection using zones of type "redirect" is not affected by this vulnerability. Affects BIND 9.9.8-S1 -> 9.9.8-S3, 9.9.9-S1 -> 9.9.9-S6, 9.11.0-9.11.0-P1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ISC | BIND 9 | BIND 9 9.9.8-S1 -> 9.9.8-S3, 9.9.9-S1 -> 9.9.9-S6, 9.11.0-9.11.0-P1 | — | No fix listed | CNA |
- BIND 9 VendorISC Affected BIND 9 9.9.8-S1 -> 9.9.8-S3, 9.9.9-S1 -> 9.9.9-S6, 9.11.0-9.11.0-P1 Fixed in — No fix listed CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:isc:bind:9.9.8:s1:*:*:*:*:*:* | 9.9.8 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.9.8:s2:*:*:*:*:*:* | 9.9.8 s2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.9.8:s3:*:*:*:*:*:* | 9.9.8 s3 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.9.9:s1:*:*:*:*:*:* | 9.9.9 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.9.9:s6:*:*:*:*:*:* | 9.9.9 s6 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.0:*:*:*:*:*:*:* | 9.11.0 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.0:p1:*:*:*:*:*:* | 9.11.0 p1 | Vulnerable | ISC |
| cpe:2.3:a:netapp:data_ontap_edge:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | NetApp |
| cpe:2.3:a:netapp:solidfire_element_os_management_node:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | NetApp |
- cpe:2.3:a:isc:bind:9.9.8:s1:*:*:*:*:*:* Versions 9.9.8 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.9.8:s2:*:*:*:*:*:* Versions 9.9.8 s2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.9.8:s3:*:*:*:*:*:* Versions 9.9.8 s3 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.9.9:s1:*:*:*:*:*:* Versions 9.9.9 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.9.9:s6:*:*:*:*:*:* Versions 9.9.9 s6 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.0:*:*:*:*:*:*:* Versions 9.11.0 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.0:p1:*:*:*:*:*:* Versions 9.11.0 p1 Vulnerable ·ISC
- cpe:2.3:a:netapp:data_ontap_edge:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
- cpe:2.3:a:netapp:solidfire_element_os_management_node:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 3 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2016-9778
- 2026-10-03 Alias added: GHSA-xf9m-fv8p-cjv5
References
More ISC Bind vulnerabilities
- TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
- TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
Sources
- CVE-2016-9778 · CVE Program
- CVE-2016-9778 · NVD
- FIRST EPSS
- GHSA-xf9m-fv8p-cjv5 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-9778 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences