The serializer in html5lib before 0.99999999 might allow remote attackers to conduct…
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of special characters in attribute values, a different vulnerability than CVE-2016-9909.
Why it matters now
EPSS 0.0216 82nd percentileScored 2026-11-07
Fix Fixed html5lib (PyPI): 0.99999999
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | html5lib (PyPI) | before 0.99999999 | 0.99999999 | Patch available | GHSA-8f6m-gfq9-g33v |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- html5lib (PyPI) Vendor— Affected before 0.99999999 Fixed in 0.99999999 Patch available GHSA-8f6m-gfq9-g33v
Remediation
- Fix · GHSA-8f6m-gfq9-g33v html5lib (PyPI) Fixed in 0.99999999 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2016-9910
- 2026-10-03 Alias added: GHSA-8f6m-gfq9-g33v
References
Patch 3
- [oss-security] 20161206 CVE Request: html5lib: potential cross-site scripting vulnerablity: quote attributes that need escaping in legacy browsers
- [oss-security] 20161208 Re: CVE Request: html5lib: potential cross-site scripting vulnerablity: quote attributes that need escaping in legacy browsers
- https://github.com/html5lib/html5lib-python/commit/9b8d8eb5afbc066b7fac9390f5ec75e5e8a7cab7
Advisory 4
More Html5lib vulnerabilities
- TI-2016-08028 The serializer in html5lib before 0.99999999 might allow remote attackers to conduct… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2016-9910 · CVE Program
- CVE-2016-9910 · NVD
- FIRST EPSS
- GHSA-8f6m-gfq9-g33v · GitHub Advisory Database · CC BY 4.0
- CVE-2016-9910 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences