Improper privilege management in MCabber
Priority MEDIUM 40CWE-269Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-269.
Summary
MCabber before 1.0.4 is vulnerable to roster push attacks, which allows remote attackers to intercept communications, or add themselves as an entity on a 3rd party's roster as another user, which will also garner associated privileges, via crafted XMPP packets.
Why it matters now
EPSS 0.04512 91st percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed MCabber (MCabber): 1.0.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| MCabber | MCabber | before 1.0.4 | 1.0.4 | Patch available | CNA |
- MCabber VendorMCabber Affected before 1.0.4 Fixed in 1.0.4 Patch available CNA
Remediation
- Fix · CNA MCabber (MCabber) Fixed in 1.0.4
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2016-9928
- 2026-10-03 Alias added: GHSA-q477-8j82-fjq4
References
Exploit 2
Patch 1
Advisory 6
- https://gultsch.de/gajim_roster_push_and_message_interception.html
- http://www.openwall.com/lists/oss-security/2017/02/09/29
- http://www.openwall.com/lists/oss-security/2016/12/11/2
- http://lists.opensuse.org/opensuse-updates/2017-01/msg00130.html
- [debian-lts-announce] 20200628 [SECURITY] [DLA 2260-1] mcabber security update
- USN-4506-1
More Mcabber vulnerabilities
- TI-2017-03606 An incorrect implementation of "XEP-0280: Message Carbons" in multiple XMPP clients… CVSS 3.0MEDIUM 5.9
Sources
- CVE-2016-9928 · CVE Program
- CVE-2016-9928 · NVD
- FIRST EPSS
- GHSA-q477-8j82-fjq4 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-9928 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences