The SimpleSAML_XML_Validator class constructor in SimpleSAMLphp before 1.14.11 might…
Priority LOW 30CWE-20Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
The SimpleSAML_XML_Validator class constructor in SimpleSAMLphp before 1.14.11 might allow remote attackers to spoof signatures on SAML 1 responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.
Why it matters now
EPSS 0.01182 67th percentileScored 2026-11-07
Fix Fixed simplesamlphp/simplesamlphp (Packagist): 1.14.11
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | simplesamlphp/simplesamlphp (Packagist) | before 1.14.11 | 1.14.11 | Patch available | GHSA-p9cm-r7jg-8q3g |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- simplesamlphp/simplesamlphp (Packagist) Vendor— Affected before 1.14.11 Fixed in 1.14.11 Patch available GHSA-p9cm-r7jg-8q3g
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* | before 1.14.11 | Vulnerable | simplesamlphp |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
- cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* Versions before 1.14.11 Vulnerable ·simplesamlphp
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-p9cm-r7jg-8q3g simplesamlphp/simplesamlphp (Packagist) Fixed in 1.14.11 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-9955
- 2026-10-03 Alias added: GHSA-p9cm-r7jg-8q3g
References
Advisory 3
Sources
- CVE-2016-9955 · CVE Program
- CVE-2016-9955 · NVD
- FIRST EPSS
- GHSA-p9cm-r7jg-8q3g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences