The setFrom function in the Sendmail adapter in the zend-mail component before 2.4.11…
Priority HIGH 69CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
The setFrom function in the Sendmail adapter in the zend-mail component before 2.4.11, 2.5.x, 2.6.x, and 2.7.x before 2.7.2, and Zend Framework before 2.4.11 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code via a \" (backslash double quote) in a crafted e-mail address.
Why it matters now
EPSS 0.38438 98th percentileScored 2026-11-07
Public exploit Yes 5 exploit referencesTagged by the CNA and NVD
Fix Fixed zendframework/zend-mail (Packagist): 2.4.11, 2.7.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | zendframework/zend-mail (Packagist) | before 2.4.11 | 2.4.11 | Patch available | GHSA-r9mw-gwx9-v3h5 |
| — | zendframework/zend-mail (Packagist) | 2.5 – 2.5.2 | — | No fix listed | GHSA-r9mw-gwx9-v3h5 |
| — | zendframework/zend-mail (Packagist) | 2.6 – 2.6.2 | — | No fix listed | GHSA-r9mw-gwx9-v3h5 |
| — | zendframework/zend-mail (Packagist) | 2.7 to before 2.7.2 | 2.7.2 | Patch available | GHSA-r9mw-gwx9-v3h5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- zendframework/zend-mail (Packagist) Vendor— Affected before 2.4.11 Fixed in 2.4.11 Patch available GHSA-r9mw-gwx9-v3h5
- zendframework/zend-mail (Packagist) Vendor— Affected 2.5 – 2.5.2 Fixed in — No fix listed GHSA-r9mw-gwx9-v3h5
- zendframework/zend-mail (Packagist) Vendor— Affected 2.6 – 2.6.2 Fixed in — No fix listed GHSA-r9mw-gwx9-v3h5
- zendframework/zend-mail (Packagist) Vendor— Affected 2.7 to before 2.7.2 Fixed in 2.7.2 Patch available GHSA-r9mw-gwx9-v3h5
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zend:zend_framework:*:*:*:*:*:*:*:* | up to 2.4.10 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend-mail:*:*:*:*:*:*:*:* | up to 2.4.10 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend-mail:2.5.0:*:*:*:*:*:*:* | 2.5.0 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend-mail:2.5.1:*:*:*:*:*:*:* | 2.5.1 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend-mail:2.5.2:*:*:*:*:*:*:* | 2.5.2 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend-mail:2.6.0:*:*:*:*:*:*:* | 2.6.0 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend-mail:2.6.1:*:*:*:*:*:*:* | 2.6.1 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend-mail:2.6.2:*:*:*:*:*:*:* | 2.6.2 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend-mail:2.7.0:*:*:*:*:*:*:* | 2.7.0 | Vulnerable | Zend |
| cpe:2.3:a:zend:zend-mail:2.7.1:*:*:*:*:*:*:* | 2.7.1 | Vulnerable | Zend |
- cpe:2.3:a:zend:zend_framework:*:*:*:*:*:*:*:* Versions up to 2.4.10 Vulnerable ·Zend
- cpe:2.3:a:zend:zend-mail:*:*:*:*:*:*:*:* Versions up to 2.4.10 Vulnerable ·Zend
- cpe:2.3:a:zend:zend-mail:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Zend
- cpe:2.3:a:zend:zend-mail:2.5.1:*:*:*:*:*:*:* Versions 2.5.1 Vulnerable ·Zend
- cpe:2.3:a:zend:zend-mail:2.5.2:*:*:*:*:*:*:* Versions 2.5.2 Vulnerable ·Zend
- cpe:2.3:a:zend:zend-mail:2.6.0:*:*:*:*:*:*:* Versions 2.6.0 Vulnerable ·Zend
- cpe:2.3:a:zend:zend-mail:2.6.1:*:*:*:*:*:*:* Versions 2.6.1 Vulnerable ·Zend
- cpe:2.3:a:zend:zend-mail:2.6.2:*:*:*:*:*:*:* Versions 2.6.2 Vulnerable ·Zend
- cpe:2.3:a:zend:zend-mail:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Zend
- cpe:2.3:a:zend:zend-mail:2.7.1:*:*:*:*:*:*:* Versions 2.7.1 Vulnerable ·Zend
Remediation
- Fix · GHSA-r9mw-gwx9-v3h5 zendframework/zend-mail (Packagist) Fixed in 2.4.11 Advisory →
- Fix · GHSA-r9mw-gwx9-v3h5 zendframework/zend-mail (Packagist) Fixed in 2.7.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10034
- 2026-10-03 Alias added: GHSA-r9mw-gwx9-v3h5
References
Exploit 5
Sources
- CVE-2016-10034 · CVE Program
- CVE-2016-10034 · NVD
- FIRST EPSS
- GHSA-r9mw-gwx9-v3h5 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-10034 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences