Read the docs
TI-2016-08269 Aliases CVE-2016-10193GHSA-4jm3-pfpf-h54p

The espeak-ruby gem before 1.0.3 for Ruby allows remote attackers to execute arbitrary…

Priority MEDIUM 47CWE-284Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.

Summary

The espeak-ruby gem before 1.0.3 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a string to the speak, save, bytes or bytes_wav method in lib/espeak/speech.rb.

Why it matters now

EPSS 0.02448 84th percentileScored 2026-11-07
Fix Fixed espeak-ruby (RubyGems): 1.0.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—espeak-ruby (RubyGems)before 1.0.31.0.3Patch availableGHSA-4jm3-pfpf-h54p
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • espeak-ruby (RubyGems) Vendor— Affected before 1.0.3 Fixed in 1.0.3 Patch available GHSA-4jm3-pfpf-h54p

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:espeak-ruby_project:espeak-ruby:*:*:*:*:*:ruby:*:*up to 1.0.2VulnerableEspeak-ruby Project
  • cpe:2.3:a:espeak-ruby_project:espeak-ruby:*:*:*:*:*:ruby:*:* Versions up to 1.0.2 Vulnerable ·Espeak-ruby Project

Remediation

  • Fix · GHSA-4jm3-pfpf-h54p espeak-ruby (RubyGems) Fixed in 1.0.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-10193
  2. 2026-10-03 Alias added: GHSA-4jm3-pfpf-h54p

References

Sources