Uncontrolled resource consumption in HackerOne i18n-node-angular node module
Priority LOW 37CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- Low · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
i18n-node-angular is a module used to interact between i18n and angular without using additional resources. A REST API endpoint that is used for development in i18n-node-angular before 1.4.0 was not disabled in production environments a malicious user could fill up the server causing a Denial of Service or content injection.
Why it matters now
EPSS 0.00789 56th percentileScored 2026-11-07
Fix Fixed i18n-node-angular node module (HackerOne): 1.4.0i18n-node-angular (npm): 1.4.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | i18n-node-angular node module | before 1.4.0 | 1.4.0 | Patch available | CNA |
| — | i18n-node-angular (npm) | before 1.4.0 | 1.4.0 | Patch available | GHSA-97gv-3p2c-xw7j |
- i18n-node-angular node module VendorHackerOne Affected before 1.4.0 Fixed in 1.4.0 Patch available CNA
- i18n-node-angular (npm) Vendor— Affected before 1.4.0 Fixed in 1.4.0 Patch available GHSA-97gv-3p2c-xw7j
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:i18n-node-angular_project:i18n-node-angular:*:*:*:*:*:node.js:*:* | before 1.4.0 | Vulnerable | I18n-node-angular Project |
- cpe:2.3:a:i18n-node-angular_project:i18n-node-angular:*:*:*:*:*:node.js:*:* Versions before 1.4.0 Vulnerable ·I18n-node-angular Project
Remediation
- Fix · CNA i18n-node-angular node module (HackerOne) Fixed in 1.4.0
- Fix · GHSA-97gv-3p2c-xw7j i18n-node-angular (npm) Fixed in 1.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10524
- 2026-10-03 Alias added: GHSA-97gv-3p2c-xw7j
References
Patch 1
Advisory 3
Sources
- CVE-2016-10524 · CVE Program
- CVE-2016-10524 · NVD
- FIRST EPSS
- GHSA-97gv-3p2c-xw7j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences