Improper authentication in HackerOne hapi-auth-jwt2 node module
Priority MEDIUM 47CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
When attempting to allow authentication mode `try` in hapi, hapi-auth-jwt2 version 5.1.1 introduced an issue whereby people could bypass authentication.
Why it matters now
EPSS 0.02439 84th percentileScored 2026-11-07
Fix Fixed hapi-auth-jwt2 (npm): 5.1.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | hapi-auth-jwt2 node module | 5.1.1 | — | No fix listed | CNA |
| — | hapi-auth-jwt2 (npm) | 5.1.1 to before 5.1.2 | 5.1.2 | Patch available | GHSA-mg8r-9g6j-hwv9 |
- hapi-auth-jwt2 node module VendorHackerOne Affected 5.1.1 Fixed in — No fix listed CNA
- hapi-auth-jwt2 (npm) Vendor— Affected 5.1.1 to before 5.1.2 Fixed in 5.1.2 Patch available GHSA-mg8r-9g6j-hwv9
Remediation
- Fix · GHSA-mg8r-9g6j-hwv9 hapi-auth-jwt2 (npm) Fixed in 5.1.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10525
- 2026-10-03 Alias added: GHSA-mg8r-9g6j-hwv9
References
Advisory 4
Sources
- CVE-2016-10525 · CVE Program
- CVE-2016-10525 · NVD
- FIRST EPSS
- GHSA-mg8r-9g6j-hwv9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences