Uncontrolled resource consumption in HackerOne riot-compiler node module
Priority LOW 36CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
The riot-compiler version version 2.3.21 has an issue in a regex (Catastrophic Backtracking) thats make it unusable under certain conditions.
Why it matters now
EPSS 0.01573 75th percentileScored 2026-11-07
Fix Fixed riot-compiler (npm): 2.3.22
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | riot-compiler node module | 2.3.21 | — | No fix listed | CNA |
| — | riot-compiler (npm) | before 2.3.22 | 2.3.22 | Patch available | GHSA-pp4v-55vr-9gxh |
- riot-compiler node module VendorHackerOne Affected 2.3.21 Fixed in — No fix listed CNA
- riot-compiler (npm) Vendor— Affected before 2.3.22 Fixed in 2.3.22 Patch available GHSA-pp4v-55vr-9gxh
Remediation
- Fix · GHSA-pp4v-55vr-9gxh riot-compiler (npm) Fixed in 2.3.22 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10527
- 2026-10-03 Alias added: GHSA-pp4v-55vr-9gxh
References
Sources
- CVE-2016-10527 · CVE Program
- CVE-2016-10527 · NVD
- FIRST EPSS
- GHSA-pp4v-55vr-9gxh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences