Path traversal in HackerOne restafary node module
Priority LOW 25CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
restafary is a REpresentful State Transfer API for Creating, Reading, Using, Deleting files on a server from the web. Restafary before 1.6.1 is able to set up a root path, which should only allow it to run inside of that root path it specified.
Why it matters now
EPSS 0.0118 67th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed restafary node module (HackerOne): 1.6.1restafary (npm): 1.6.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | restafary node module | before 1.6.1 | 1.6.1 | Patch available | CNA |
| — | restafary (npm) | before 1.6.1 | 1.6.1 | Patch available | GHSA-xg5r-8j97-2wrj |
- restafary node module VendorHackerOne Affected before 1.6.1 Fixed in 1.6.1 Patch available CNA
- restafary (npm) Vendor— Affected before 1.6.1 Fixed in 1.6.1 Patch available GHSA-xg5r-8j97-2wrj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:restafary_project:restafary:*:*:*:*:*:node.js:*:* | before 1.6.1 | Vulnerable | Restafary Project |
- cpe:2.3:a:restafary_project:restafary:*:*:*:*:*:node.js:*:* Versions before 1.6.1 Vulnerable ·Restafary Project
Remediation
- Fix · CNA restafary node module (HackerOne) Fixed in 1.6.1
- Fix · GHSA-xg5r-8j97-2wrj restafary (npm) Fixed in 1.6.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10528
- 2026-10-03 Alias added: GHSA-xg5r-8j97-2wrj
References
Sources
- CVE-2016-10528 · CVE Program
- CVE-2016-10528 · NVD
- FIRST EPSS
- GHSA-xg5r-8j97-2wrj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences