Improper authentication in HackerOne console-io node module
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
console-io is a module that allows users to implement a web console in their application. A malicious user could bypass the authentication and execute any command that the user who is running the console-io application 2.2.13 and earlier is able to run. This means that if console-io was running from root, the attacker would have full access to the system. This vulnerability exists because the console-io application does not configure socket.io to require authentication, which allows a malicious user to connect via a websocket to send commands and receive the response.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | console-io node module | up to 2.2.13 | — | No fix listed | CNA |
| — | console-io (npm) | before 2.3.0 | 2.3.0 | Patch available | GHSA-q52j-4q2q-hcj6 |
- console-io node module VendorHackerOne Affected up to 2.2.13 Fixed in — No fix listed CNA
- console-io (npm) Vendor— Affected before 2.3.0 Fixed in 2.3.0 Patch available GHSA-q52j-4q2q-hcj6
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:console-io_project:console-io:*:*:*:*:*:node.js:*:* | up to 2.2.13 | Vulnerable | Console-io Project |
- cpe:2.3:a:console-io_project:console-io:*:*:*:*:*:node.js:*:* Versions up to 2.2.13 Vulnerable ·Console-io Project
Remediation
- Fix · GHSA-q52j-4q2q-hcj6 console-io (npm) Fixed in 2.3.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10532
- 2026-10-03 Alias added: GHSA-q52j-4q2q-hcj6
References
Sources
- CVE-2016-10532 · CVE Program
- CVE-2016-10532 · NVD
- FIRST EPSS
- GHSA-q52j-4q2q-hcj6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences