Information disclosure in HackerOne express-restify-mongoose node module
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
express-restify-mongoose is a module to easily create a flexible REST interface for mongoose models. express-restify-mongoose 2.4.2 and earlier and 3.0.X through 3.0.1 allows a malicious user to send a request for `GET /User?distinct=password` and get all the passwords for all the users in the database, despite the field being set to private. This can be used for other private data if the malicious user knew what was set as private for specific routes.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | express-restify-mongoose node module | <= 2.4.2 || >= 3.0.0 <=3.0.1 | — | No fix listed | CNA |
| — | express-restify-mongoose (npm) | 3.0.0 to before 3.1.0 | 3.1.0 | Patch available | GHSA-cgjx-mwpx-47jv |
| — | express-restify-mongoose (npm) | before 2.5.0 | 2.5.0 | Patch available | GHSA-cgjx-mwpx-47jv |
- express-restify-mongoose node module VendorHackerOne Affected <= 2.4.2 || >= 3.0.0 <=3.0.1 Fixed in — No fix listed CNA
- express-restify-mongoose (npm) Vendor— Affected 3.0.0 to before 3.1.0 Fixed in 3.1.0 Patch available GHSA-cgjx-mwpx-47jv
- express-restify-mongoose (npm) Vendor— Affected before 2.5.0 Fixed in 2.5.0 Patch available GHSA-cgjx-mwpx-47jv
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:express-restify-mongoose_project:express-restify-mongoose:*:*:*:*:*:node.js:*:* | up to 2.4.2; 3.0.0 – 3.0.1 | Vulnerable | Express-restify-mongoose Project |
- cpe:2.3:a:express-restify-mongoose_project:express-restify-mongoose:*:*:*:*:*:node.js:*:* Versions up to 2.4.2; 3.0.0 – 3.0.1 Vulnerable ·Express-restify-mongoose Project
Remediation
- Fix · GHSA-cgjx-mwpx-47jv express-restify-mongoose (npm) Fixed in 3.1.0 Advisory →
- Fix · GHSA-cgjx-mwpx-47jv express-restify-mongoose (npm) Fixed in 2.5.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10533
- 2026-10-03 Alias added: GHSA-cgjx-mwpx-47jv
References
Advisory 3
Other 4
- https://github.com/florianholzapfel/express-restify-mongoose/pull/253
- https://github.com/florianholzapfel/express-restify-mongoose/commit/23ccb247d0074bfaca6737cdff52d89c6d6e4a7c
- https://github.com/florianholzapfel/express-restify-mongoose/commit/746defcd808e2ed1e8931dc36702b25b7db0e94b
- https://www.npmjs.com/advisories/92
Sources
- CVE-2016-10533 · CVE Program
- CVE-2016-10533 · NVD
- FIRST EPSS
- GHSA-cgjx-mwpx-47jv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences