Code injection in HackerOne pouchdb node module
Priority MEDIUM 47CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
An arbitrary code injection vector was found in PouchDB 6.0.4 and lesser via the map/reduce functions used in PouchDB temporary views and design documents. The code execution engine for this branch is not properly sandboxed and may be used to run arbitrary JavaScript as well as system commands.
Why it matters now
EPSS 0.02565 85th percentileScored 2026-11-07
Fix Fixed pouchdb (npm): 6.0.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | pouchdb node module | up to 6.0.4 | — | No fix listed | CNA |
| — | pouchdb (npm) | before 6.0.5 | 6.0.5 | Patch available | GHSA-cgqv-x5cx-xvqh |
- pouchdb node module VendorHackerOne Affected up to 6.0.4 Fixed in — No fix listed CNA
- pouchdb (npm) Vendor— Affected before 6.0.5 Fixed in 6.0.5 Patch available GHSA-cgqv-x5cx-xvqh
Remediation
- Fix · GHSA-cgqv-x5cx-xvqh pouchdb (npm) Fixed in 6.0.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10546
- 2026-10-03 Alias added: GHSA-cgqv-x5cx-xvqh
References
Sources
- CVE-2016-10546 · CVE Program
- CVE-2016-10546 · NVD
- FIRST EPSS
- GHSA-cgqv-x5cx-xvqh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences