Cryptographic flaw in HackerOne appium-chromedriver node module
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-311.
Summary
appium-chromedriver is a Node.js wrapper around Chromedriver. Versions below 2.9.4 download binary resources over HTTP, which leaves the module vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | appium-chromedriver node module | before 2.9.4 | 2.9.4 | Patch available | CNA |
| — | appium-chromedriver (npm) | before 2.9.4 | 2.9.4 | Patch available | GHSA-hc94-2wfr-4pwf |
- appium-chromedriver node module VendorHackerOne Affected before 2.9.4 Fixed in 2.9.4 Patch available CNA
- appium-chromedriver (npm) Vendor— Affected before 2.9.4 Fixed in 2.9.4 Patch available GHSA-hc94-2wfr-4pwf
Remediation
- Fix · CNA appium-chromedriver node module (HackerOne) Fixed in 2.9.4
- Fix · GHSA-hc94-2wfr-4pwf appium-chromedriver (npm) Fixed in 2.9.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10557
- 2026-10-03 Alias added: GHSA-hc94-2wfr-4pwf
References
Sources
- CVE-2016-10557 · CVE Program
- CVE-2016-10557 · NVD
- FIRST EPSS
- GHSA-hc94-2wfr-4pwf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences