Cryptographic flaw in HackerOne galenframework-cli node module
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-311.
Summary
galenframework-cli is the node wrapper for the Galen Framework. galenframework-cli below 2.3.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | galenframework-cli node module | before 2.3.1 | 2.3.1 | Patch available | CNA |
| — | galenframework-cli (npm) | before 2.3.1 | 2.3.1 | Patch available | GHSA-x5ph-4fr4-g7fw |
- galenframework-cli node module VendorHackerOne Affected before 2.3.1 Fixed in 2.3.1 Patch available CNA
- galenframework-cli (npm) Vendor— Affected before 2.3.1 Fixed in 2.3.1 Patch available GHSA-x5ph-4fr4-g7fw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:galenframework:galenframework-cli:*:*:*:*:*:node.js:*:* | before 2.3.1 | Vulnerable | Galenframework |
- cpe:2.3:a:galenframework:galenframework-cli:*:*:*:*:*:node.js:*:* Versions before 2.3.1 Vulnerable ·Galenframework
Remediation
- Fix · CNA galenframework-cli node module (HackerOne) Fixed in 2.3.1
- Fix · GHSA-x5ph-4fr4-g7fw galenframework-cli (npm) Fixed in 2.3.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10560
- 2026-10-03 Alias added: GHSA-x5ph-4fr4-g7fw
References
Sources
- CVE-2016-10560 · CVE Program
- CVE-2016-10560 · NVD
- FIRST EPSS
- GHSA-x5ph-4fr4-g7fw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences