Cryptographic flaw in HackerOne geoip-lite-country node module
Priority LOW 36CWE-311Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-311.
Summary
geoip-lite-country is a stripped down version of geoip-lite, supporting only country lookup. geoip-lite-country before 1.1.4 downloads data resources over HTTP, which leaves it vulnerable to MITM attacks.
Why it matters now
EPSS 0.00558 46th percentileScored 2026-11-07
Fix Fixed geoip-lite-country node module (HackerOne): 1.1.4geoip-lite-country (npm): 1.1.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | geoip-lite-country node module | before 1.1.4 | 1.1.4 | Patch available | CNA |
| — | geoip-lite-country (npm) | before 1.1.4 | 1.1.4 | Patch available | GHSA-ff29-f57w-2mm3 |
- geoip-lite-country node module VendorHackerOne Affected before 1.1.4 Fixed in 1.1.4 Patch available CNA
- geoip-lite-country (npm) Vendor— Affected before 1.1.4 Fixed in 1.1.4 Patch available GHSA-ff29-f57w-2mm3
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:geoip-lite-country_project:geoip-lite-country:*:*:*:*:*:node.js:*:* | before 1.1.4 | Vulnerable | Geoip-lite-country Project |
- cpe:2.3:a:geoip-lite-country_project:geoip-lite-country:*:*:*:*:*:node.js:*:* Versions before 1.1.4 Vulnerable ·Geoip-lite-country Project
Remediation
- Fix · CNA geoip-lite-country node module (HackerOne) Fixed in 1.1.4
- Fix · GHSA-ff29-f57w-2mm3 geoip-lite-country (npm) Fixed in 1.1.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10568
- 2026-10-03 Alias added: GHSA-ff29-f57w-2mm3
References
Sources
- CVE-2016-10568 · CVE Program
- CVE-2016-10568 · NVD
- FIRST EPSS
- GHSA-ff29-f57w-2mm3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences