Cryptographic flaw in HackerOne pngcrush-installer node module
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-311.
Summary
pngcrush-installer is an installer for Pngcrush. pngcrush-installer versions below 1.8.10 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | pngcrush-installer node module | before 1.8.10 | 1.8.10 | Patch available | CNA |
| — | pngcrush-installer (npm) | before 1.8.10 | 1.8.10 | Patch available | GHSA-g93h-75m9-3qq4 |
- pngcrush-installer node module VendorHackerOne Affected before 1.8.10 Fixed in 1.8.10 Patch available CNA
- pngcrush-installer (npm) Vendor— Affected before 1.8.10 Fixed in 1.8.10 Patch available GHSA-g93h-75m9-3qq4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pngcrush-installer_project:pngcrush-installer:*:*:*:*:*:node.js:*:* | before 1.8.10 | Vulnerable | Pngcrush-installer Project |
- cpe:2.3:a:pngcrush-installer_project:pngcrush-installer:*:*:*:*:*:node.js:*:* Versions before 1.8.10 Vulnerable ·Pngcrush-installer Project
Remediation
- Fix · CNA pngcrush-installer node module (HackerOne) Fixed in 1.8.10
- Fix · GHSA-g93h-75m9-3qq4 pngcrush-installer (npm) Fixed in 1.8.10 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10570
- 2026-10-03 Alias added: GHSA-g93h-75m9-3qq4
References
Sources
- CVE-2016-10570 · CVE Program
- CVE-2016-10570 · NVD
- FIRST EPSS
- GHSA-g93h-75m9-3qq4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences