Cryptographic flaw in HackerOne mongodb-instance node module
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-311.
Summary
mongodb-instance before 0.0.3 installs mongodb locally. mongodb-instance downloads binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | mongodb-instance node module | before 0.0.3 | 0.0.3 | Patch available | CNA |
| — | mongodb-instance (npm) | before 0.0.3 | 0.0.3 | Patch available | GHSA-7r8m-45gc-m2c8 |
- mongodb-instance node module VendorHackerOne Affected before 0.0.3 Fixed in 0.0.3 Patch available CNA
- mongodb-instance (npm) Vendor— Affected before 0.0.3 Fixed in 0.0.3 Patch available GHSA-7r8m-45gc-m2c8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mongodb-instance_project:mongodb-instance:*:*:*:*:*:node.js:*:* | before 0.0.3 | Vulnerable | Mongodb-instance Project |
- cpe:2.3:a:mongodb-instance_project:mongodb-instance:*:*:*:*:*:node.js:*:* Versions before 0.0.3 Vulnerable ·Mongodb-instance Project
Remediation
- Fix · CNA mongodb-instance node module (HackerOne) Fixed in 0.0.3
- Fix · GHSA-7r8m-45gc-m2c8 mongodb-instance (npm) Fixed in 0.0.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10572
- 2026-10-03 Alias added: GHSA-7r8m-45gc-m2c8
References
Sources
- CVE-2016-10572 · CVE Program
- CVE-2016-10572 · NVD
- FIRST EPSS
- GHSA-7r8m-45gc-m2c8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences