Read the docs
TI-2016-08617 Aliases CVE-2016-10576GHSA-3627-w2qr-5fxr

Cryptographic flaw in HackerOne fuseki node module

Priority LOW 39CWE-311Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Information disclosure
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-311.

Summary

Fuseki server wrapper and management API in fuseki before 1.0.1 downloads binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested resources with an attacker controlled copy if the attacker is on the network or positioned in between the user and the remote server.

Why it matters now

EPSS 0.01656 76th percentileScored 2026-11-07
Fix Fixed fuseki node module (HackerOne): 1.0.1fuseki (npm): 1.0.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
HackerOnefuseki node modulebefore 1.0.11.0.1Patch availableCNA
—fuseki (npm)before 1.0.11.0.1Patch availableGHSA-3627-w2qr-5fxr
  • fuseki node module VendorHackerOne Affected before 1.0.1 Fixed in 1.0.1 Patch available CNA
  • fuseki (npm) Vendor— Affected before 1.0.1 Fixed in 1.0.1 Patch available GHSA-3627-w2qr-5fxr

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:fuseki_project:fuseki:*:*:*:*:*:node.js:*:*before 1.0.1VulnerableFuseki Project
  • cpe:2.3:a:fuseki_project:fuseki:*:*:*:*:*:node.js:*:* Versions before 1.0.1 Vulnerable ·Fuseki Project

Remediation

  • Fix · CNA fuseki node module (HackerOne) Fixed in 1.0.1
  • Fix · GHSA-3627-w2qr-5fxr fuseki (npm) Fixed in 1.0.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-10576
  2. 2026-10-03 Alias added: GHSA-3627-w2qr-5fxr

References

Sources