Cryptographic flaw in HackerOne nw node module
Priority LOW 39CWE-311Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-311.
Summary
nw is an installer for nw.js. nw downloads zipped resources over HTTP, It may be possible to cause remote code execution (RCE) by swapping out the requested zip file with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Why it matters now
EPSS 0.01728 77th percentileScored 2026-11-07
Fix Fixed nw (npm): 0.23.6-1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | nw node module | All versions | — | No fix listed | CNA |
| — | nw (npm) | before 0.23.6-1 | 0.23.6-1 | Patch available | GHSA-hv96-xxx2-5v7w |
- nw node module VendorHackerOne Affected All versions Fixed in — No fix listed CNA
- nw (npm) Vendor— Affected before 0.23.6-1 Fixed in 0.23.6-1 Patch available GHSA-hv96-xxx2-5v7w
Remediation
- Fix · GHSA-hv96-xxx2-5v7w nw (npm) Fixed in 0.23.6-1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10588
- 2026-10-03 Alias added: GHSA-hv96-xxx2-5v7w
References
More Nwjs Nw vulnerabilities
- TI-2014-07752 A vulnerability exists in nw.js before 0.11.3 when calling nw methods from normal frames… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2016-10588 · CVE Program
- CVE-2016-10588 · NVD
- FIRST EPSS
- GHSA-hv96-xxx2-5v7w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences