Read the docs
TI-2016-08632 Aliases CVE-2016-10591GHSA-cr79-9pwf-r6f5

Cryptographic flaw in HackerOne prince node module

Priority LOW 39CWE-311Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Information disclosure, Privilege escalation
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-311 and CWE-269.

Summary

Prince is a Node API for executing XML/HTML to PDF renderer PrinceXML via prince(1) CLI. prince downloads zipped resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested tarball with an attacker controlled tarball if the attacker is on the network or positioned in between the user and the remote server.

Why it matters now

EPSS 0.01692 77th percentileScored 2026-11-07
Fix Fixed prince (npm): 1.4.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
HackerOneprince node moduleAll versions—No fix listedCNA
—prince (npm)before 1.4.71.4.7Patch availableGHSA-cr79-9pwf-r6f5
  • prince node module VendorHackerOne Affected All versions Fixed in — No fix listed CNA
  • prince (npm) Vendor— Affected before 1.4.7 Fixed in 1.4.7 Patch available GHSA-cr79-9pwf-r6f5

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:prince_project:prince:*:*:*:*:*:node.js:*:*1.4.4 to before 1.4.6VulnerablePrince Project
  • cpe:2.3:a:prince_project:prince:*:*:*:*:*:node.js:*:* Versions 1.4.4 to before 1.4.6 Vulnerable ·Prince Project

Remediation

  • Fix · GHSA-cr79-9pwf-r6f5 prince (npm) Fixed in 1.4.7 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-10591
  2. 2026-10-03 Alias added: GHSA-cr79-9pwf-r6f5

References

Sources