Cryptographic flaw in HackerOne limbus-buildgen node module
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-311.
Summary
limbus-buildgen is a "build anywhere" build system. limbus-buildgen versions below 0.1.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested resources with an attacker controlled copy if the attacker is on the network or positioned in between the user and the remote server.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | limbus-buildgen node module | before 0.1.1 | 0.1.1 | Patch available | CNA |
| — | limbus-buildgen (npm) | before 0.1.1 | 0.1.1 | Patch available | GHSA-rj38-87f3-93p6 |
- limbus-buildgen node module VendorHackerOne Affected before 0.1.1 Fixed in 0.1.1 Patch available CNA
- limbus-buildgen (npm) Vendor— Affected before 0.1.1 Fixed in 0.1.1 Patch available GHSA-rj38-87f3-93p6
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:limbus-buildgen_project:limbus-buildgen:*:*:*:*:*:node.js:*:* | before 0.1.1 | Vulnerable | Limbus-buildgen Project |
- cpe:2.3:a:limbus-buildgen_project:limbus-buildgen:*:*:*:*:*:node.js:*:* Versions before 0.1.1 Vulnerable ·Limbus-buildgen Project
Remediation
- Fix · CNA limbus-buildgen node module (HackerOne) Fixed in 0.1.1
- Fix · GHSA-rj38-87f3-93p6 limbus-buildgen (npm) Fixed in 0.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10674
- 2026-10-03 Alias added: GHSA-rj38-87f3-93p6
References
Sources
- CVE-2016-10674 · CVE Program
- CVE-2016-10674 · NVD
- FIRST EPSS
- GHSA-rj38-87f3-93p6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences