Cryptographic flaw in HackerOne alto-saxophone node module
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-311.
Summary
alto-saxophone is a module to install and launch Chromedriver for Mac, Linux or Windows. alto-saxophone versions below 2.25.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | alto-saxophone node module | before 2.25.1 | 2.25.1 | Patch available | CNA |
| — | alto-saxophone (npm) | before 2.25.1 | 2.25.1 | Patch available | GHSA-2p69-gxpm-5469 |
- alto-saxophone node module VendorHackerOne Affected before 2.25.1 Fixed in 2.25.1 Patch available CNA
- alto-saxophone (npm) Vendor— Affected before 2.25.1 Fixed in 2.25.1 Patch available GHSA-2p69-gxpm-5469
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:alto-saxophone_project:alto-saxophone:*:*:*:*:*:node.js:*:* | before 2.25.1 | Vulnerable | Alto-saxophone Project |
- cpe:2.3:a:alto-saxophone_project:alto-saxophone:*:*:*:*:*:node.js:*:* Versions before 2.25.1 Vulnerable ·Alto-saxophone Project
Remediation
- Fix · CNA alto-saxophone node module (HackerOne) Fixed in 2.25.1
- Fix · GHSA-2p69-gxpm-5469 alto-saxophone (npm) Fixed in 2.25.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10694
- 2026-10-03 Alias added: GHSA-2p69-gxpm-5469
References
Sources
- CVE-2016-10694 · CVE Program
- CVE-2016-10694 · NVD
- FIRST EPSS
- GHSA-2p69-gxpm-5469 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences