University of Cambridge django-ucamlookup Lookup cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
** UNSUPPORTED WHEN ASSIGNED ** A vulnerability classified as problematic was found in University of Cambridge django-ucamlookup up to 1.9.1. Affected by this vulnerability is an unknown functionality of the component Lookup Handler. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.9.2 is able to address this issue. The identifier of the patch is 5e25e4765637ea4b9e0bf5fcd5e9a922abee7eb3. It is recommended to upgrade the affected component. The identifier VDB-217441 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| University of Cambridge | django-ucamlookup | 1.9.0; 1.9.1 | — | No fix listed | CNA |
| — | django-ucamlookup (PyPI) | before 1.9.2 | 1.9.2 | Patch available | GHSA-pjx4-3f3p-29v3 |
- django-ucamlookup VendorUniversity of Cambridge Affected 1.9.0; 1.9.1 Fixed in — No fix listed CNA
- django-ucamlookup (PyPI) Vendor— Affected before 1.9.2 Fixed in 1.9.2 Patch available GHSA-pjx4-3f3p-29v3
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:django-ucamlookup_project:django-ucamlookup:*:*:*:*:*:*:*:* | before 1.9.2 | Vulnerable | Django-ucamlookup Project |
- cpe:2.3:a:django-ucamlookup_project:django-ucamlookup:*:*:*:*:*:*:*:* Versions before 1.9.2 Vulnerable ·Django-ucamlookup Project
Remediation
- Fix · GHSA-pjx4-3f3p-29v3 django-ucamlookup (PyPI) Fixed in 1.9.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-15010
- 2026-10-03 Alias added: GHSA-pjx4-3f3p-29v3
References
Patch 2
More University of Cambridge vulnerabilities
- TI-2004-00365 Stack-based buffer overflow in Exim 3.35, and other versions before 4, when the… CVSS 2.0HIGH 7.5
- TI-2001-00663 Format string vulnerability in exim (3.22-10 in Red Hat, 3.12 in Debian and 3.16 in… CVSS 2.0HIGH 7.5
- TI-2004-00366 Stack-based buffer overflow in Exim 4 before 4.33, when the headers_check_syntax option… CVSS 2.0HIGH 7.5
- TI-2001-00846 Exim 3.22 and earlier, in some configurations, does not properly verify the local part of… CVSS 2.0HIGH 7.5
- TI-2003-00686 Heap-based buffer overflow in smtp_in.c for Exim 3 (exim3) before 3.36 and Exim 4 (exim4)… CVSS 2.0HIGH 7.5
- TI-2005-00021 Multiple buffer overflows in Exim before 4.43 may allow attackers to execute arbitrary… CVSS 2.0HIGH 7.2
Sources
- CVE-2016-15010 · CVE Program
- CVE-2016-15010 · NVD
- FIRST EPSS
- GHSA-pjx4-3f3p-29v3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences