mosbth cimage check_system.php cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A vulnerability was found in mosbth cimage up to 0.7.18. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file check_system.php. The manipulation of the argument $_SERVER['SERVER_SOFTWARE'] leads to cross site scripting. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 0.7.19 is able to address this issue. The patch is named 401478c8393989836beeddfeac5ce44570af162b. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-219715.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| mosbth | cimage | 0.7.0; 0.7.1; 0.7.2; 0.7.3; 0.7.4; 0.7.5; 0.7.6; 0.7.7; 0.7.8; 0.7.9; 0.7.10; 0.7.11; 0.7.12; 0.7.13; 0.7.14; 0.7.15; 0.7.16; 0.7.17; 0.7.18 | — | No fix listed | CNA |
| — | mos/cimage (Packagist) | before 0.7.19 | 0.7.19 | Patch available | GHSA-6hv3-9fqx-8pg5 |
- cimage Vendormosbth Affected 0.7.0; 0.7.1; 0.7.2; 0.7.3; 0.7.4; 0.7.5; 0.7.6; 0.7.7; 0.7.8; 0.7.9; 0.7.10; 0.7.11; 0.7.12; 0.7.13; 0.7.14; 0.7.15; 0.7.16; 0.7.17; 0.7.18 Fixed in — No fix listed CNA
- mos/cimage (Packagist) Vendor— Affected before 0.7.19 Fixed in 0.7.19 Patch available GHSA-6hv3-9fqx-8pg5
Remediation
- Fix · GHSA-6hv3-9fqx-8pg5 mos/cimage (Packagist) Fixed in 0.7.19 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-15022
- 2026-10-03 Alias added: GHSA-6hv3-9fqx-8pg5
References
Sources
- CVE-2016-15022 · CVE Program
- CVE-2016-15022 · NVD
- FIRST EPSS
- GHSA-6hv3-9fqx-8pg5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences