generator-hottowel 404 Error _app.js cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A vulnerability, which was classified as problematic, was found in generator-hottowel 0.0.11. Affected is an unknown function of the file app/templates/src/server/_app.js of the component 404 Error Handler. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. The name of the patch is c17092fd4103143a9ddab93c8983ace8bf174396. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-221484.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | generator-hottowel | 0.0.11 | — | No fix listed | CNA |
| — | generator-hottowel (npm) | before 0.5.0 | 0.5.0 | Patch available | GHSA-f8hv-rx9p-f9r4 |
- generator-hottowel Vendor— Affected 0.0.11 Fixed in — No fix listed CNA
- generator-hottowel (npm) Vendor— Affected before 0.5.0 Fixed in 0.5.0 Patch available GHSA-f8hv-rx9p-f9r4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:generator-hottowel_project:generator-hottowel:0.0.11:*:*:*:*:node.js:*:* | 0.0.11 | Vulnerable | Generator-hottowel Project |
- cpe:2.3:a:generator-hottowel_project:generator-hottowel:0.0.11:*:*:*:*:node.js:*:* Versions 0.0.11 Vulnerable ·Generator-hottowel Project
Remediation
- Fix · GHSA-f8hv-rx9p-f9r4 generator-hottowel (npm) Fixed in 0.5.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-15025
- 2026-10-03 Alias added: GHSA-f8hv-rx9p-f9r4
References
Sources
- CVE-2016-15025 · CVE Program
- CVE-2016-15025 · NVD
- FIRST EPSS
- GHSA-f8hv-rx9p-f9r4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences