Kaltura < 11.1.0-2 PHP Object Injection RCE
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
A remote code execution vulnerability exists in Kaltura versions prior to 11.1.0-2 due to unsafe deserialization of user-controlled data within the keditorservices module. An unauthenticated remote attacker can exploit this issue by sending a specially crafted serialized PHP object in the kdata GET parameter to the redirectWidgetCmd endpoint. Successful exploitation leads to execution of arbitrary PHP code in the context of the web server process.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Video Platform (Kaltura) Fixed in 11.1.0-2
Timeline
- 2026-10-02 Threatist record created from CVE-2016-15044
- 2026-10-03 Alias added: GHSA-pmqv-6896-rrvg
References
More Kaltura vulnerabilities
- TI-2017-10304 The getUserzoneCookie function in Kaltura before 13.2.0 uses a hardcoded cookie secret to… CVSS 3.0CRITICAL 9.8
- TI-2026-16143 Improper input validation in Kaltura HTML5 Video Player, html5 library CVSS 3.1CRITICAL 9.8
- TI-2026-16144 Improper input validation in Kaltura HTML5 Video Player, html5lib library CVSS 3.1HIGH 7.5
- TI-2017-10302 The wiki_decode Developer System Helper function in the admin panel in Kaltura before… CVSS 3.1HIGH 7.2
- TI-2017-10303 Multiple cross-site scripting (XSS) vulnerabilities in Kaltura before 13.2.0 allow remote… CVSS 3.0MEDIUM 6.1
- TI-2017-04199 An issue was discovered in Kaltura server Lynx-12.11.0. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2016-15044 · CVE Program
- CVE-2016-15044 · NVD
- FIRST EPSS
- GHSA-pmqv-6896-rrvg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences