Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be…
Priority LOW 35CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query.
Why it matters now
EPSS 0.01117 66th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed knex (npm): 2.4.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | knex (npm) | before 2.4.0 | 2.4.0 | Patch available | GHSA-4jv9-3563-23j3 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- knex (npm) Vendor— Affected before 2.4.0 Fixed in 2.4.0 Patch available GHSA-4jv9-3563-23j3
Remediation
- Fix · GHSA-4jv9-3563-23j3 knex (npm) Fixed in 2.4.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2016-20018
- 2026-10-03 Alias added: GHSA-4jv9-3563-23j3
References
More Knexjs Knex vulnerabilities
- TI-2019-08022 SQL injection in knex.js CVSS 3.1CRITICAL 9.8
Sources
- CVE-2016-20018 · CVE Program
- CVE-2016-20018 · NVD
- FIRST EPSS
- GHSA-4jv9-3563-23j3 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-20018 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences