In the Bouncy Castle JCE Provider version 1.55 and earlier the DSA key pair generator…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 3 fixed, 4 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
In the Bouncy Castle JCE Provider version 1.55 and earlier the DSA key pair generator generates a weak private key if used with default values. If the JCA key pair generator is not explicitly initialised with DSA parameters, 1.55 and earlier generates a private value assuming a 1024 bit key size. In earlier releases this can be dealt with by explicitly passing parameters to the key pair generator.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.bouncycastle:bcprov-jdk14 (Maven) | before 1.56 | 1.56 | Patch available | GHSA-rrvx-pwf8-p59p |
| — | org.bouncycastle:bcprov-jdk15 (Maven) | before 1.56 | 1.56 | Patch available | GHSA-rrvx-pwf8-p59p |
| — | org.bouncycastle:bcprov-jdk15on (Maven) | before 1.56 | 1.56 | Patch available | GHSA-rrvx-pwf8-p59p |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.bouncycastle:bcprov-jdk14 (Maven) Vendor— Affected before 1.56 Fixed in 1.56 Patch available GHSA-rrvx-pwf8-p59p
- org.bouncycastle:bcprov-jdk15 (Maven) Vendor— Affected before 1.56 Fixed in 1.56 Patch available GHSA-rrvx-pwf8-p59p
- org.bouncycastle:bcprov-jdk15on (Maven) Vendor— Affected before 1.56 Fixed in 1.56 Patch available GHSA-rrvx-pwf8-p59p
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:bouncycastle:bc-java:*:*:*:*:*:*:*:* | up to 1.55 | Vulnerable | Legion of the Bouncy Castle Inc. |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:bouncycastle:bc-java:*:*:*:*:*:*:*:* Versions up to 1.55 Vulnerable ·Legion of the Bouncy Castle Inc.
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-rrvx-pwf8-p59p org.bouncycastle:bcprov-jdk14 (Maven) Fixed in 1.56 Advisory →
- Fix · GHSA-rrvx-pwf8-p59p org.bouncycastle:bcprov-jdk15 (Maven) Fixed in 1.56 Advisory →
- Fix · GHSA-rrvx-pwf8-p59p org.bouncycastle:bcprov-jdk15on (Maven) Fixed in 1.56 Advisory →
Red Hat 2 advisories
- RHSA-2018:2927 Released 2018-10-16 · Red Hat rating ImportantSatellite 6.4 security, bug fix, and enhancement update
- Red Hat Satellite 6.4 SOAPpy-0.11.6-17.el7, ansiblerole-insights-client-1.5-1.el7sat, candlepin-2.4.8-1.el7 +47
- Red Hat Satellite Capsule 6.4 SOAPpy-0.11.6-17.el7, ansiblerole-insights-client-1.5-1.el7sat, createrepo_c-0.7.4-1.el7sat +47
- RHSA-2018:2669 Released 2018-09-11 · Red Hat rating ImportantFuse 7.1 security update
- Red Hat Fuse 7
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat JBoss Data Virtualization 6 | Affected | No fix planned: Out of support scope |
| Red Hat JBoss Fuse 6 | Affected | No fix planned: Will not fix |
| Red Hat Software Collections | Affected | No fix planned: Will not fix |
| Red Hat Subscription Asset Manager | Affected | No fix planned: Will not fix |
| Red Hat Fuse 7 | Fixed | RHSA-2018:2669 |
| Red Hat Satellite 6.4 | Fixed | RHSA-2018:2927 |
| Red Hat Satellite Capsule 6.4 | Fixed | RHSA-2018:2927 |
Not affected: 7 products
- JBoss Developer Studio 11
- Red Hat JBoss Data Grid 7
- Red Hat JBoss Enterprise Application Platform 7
- Red Hat JBoss Fuse Integration Service 2
- Red Hat OpenShift Application Runtimes
- Red Hat Single Sign-On 7
- Red Hat Virtualization 4
Timeline
- 2026-10-02 Threatist record created from CVE-2016-1000343
- 2026-10-03 Alias added: GHSA-rrvx-pwf8-p59p
- 2026-11-03 Fix available: Red Hat Fuse 7 · Red Hat
References
Advisory 6
Other 7
- [lucene-solr-user] 20190104 Re: SOLR v7 Security Issues Caused Denial of Use - Sonatype Application Composition Report
- https://www.oracle.com/security-alerts/cpuoct2020.html
- https://security.netapp.com/advisory/ntap-20181127-0004/
- https://github.com/bcgit/bc-java
- https://lists.apache.org/thread.html/708d94141126eac03011144a971a6411fcac16d9c248d1d535a39451@%3Csolr-user.lucene.apache.org%3E
- https://security.netapp.com/advisory/ntap-20181127-0004
- https://usn.ubuntu.com/3727-1
Sources
- CVE-2016-1000343 · CVE Program
- CVE-2016-1000343 · NVD
- FIRST EPSS
- GHSA-rrvx-pwf8-p59p · GitHub Advisory Database · CC BY 4.0
- CVE-2016-1000343 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences