Server-side request forgery in recurly python module
Priority MEDIUM 47CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
The Recurly Client Python Library before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 is vulnerable to a Server-Side Request Forgery vulnerability in the "Resource.get" method that could result in compromise of API keys or other critical resources.
Why it matters now
EPSS 0.02616 85th percentileScored 2026-11-07
Fix Fixed recurly (PyPI): 2.6.2, 2.5.1, 2.4.5 +4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Recurly | recurly python module | Versions before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 | — | No fix listed | CNA |
| — | recurly (PyPI) | 2.6.0 to before 2.6.2 | 2.6.2 | Patch available | GHSA-38rv-5jqc-m2cv |
| — | recurly (PyPI) | 2.5.0 to before 2.5.1 | 2.5.1 | Patch available | GHSA-38rv-5jqc-m2cv |
| — | recurly (PyPI) | 2.4.0 to before 2.4.5 | 2.4.5 | Patch available | GHSA-38rv-5jqc-m2cv |
| — | recurly (PyPI) | 2.3.0 to before 2.3.1 | 2.3.1 | Patch available | GHSA-38rv-5jqc-m2cv |
| — | recurly (PyPI) | 2.2.0 to before 2.2.22 | 2.2.22 | Patch available | GHSA-38rv-5jqc-m2cv |
| — | recurly (PyPI) | 2.1.0 to before 2.1.16 | 2.1.16 | Patch available | GHSA-38rv-5jqc-m2cv |
| — | recurly (PyPI) | before 2.0.5 | 2.0.5 | Patch available | GHSA-38rv-5jqc-m2cv |
- recurly python module VendorRecurly Affected Versions before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 Fixed in — No fix listed CNA
- recurly (PyPI) Vendor— Affected 2.6.0 to before 2.6.2 Fixed in 2.6.2 Patch available GHSA-38rv-5jqc-m2cv
- recurly (PyPI) Vendor— Affected 2.5.0 to before 2.5.1 Fixed in 2.5.1 Patch available GHSA-38rv-5jqc-m2cv
- recurly (PyPI) Vendor— Affected 2.4.0 to before 2.4.5 Fixed in 2.4.5 Patch available GHSA-38rv-5jqc-m2cv
- recurly (PyPI) Vendor— Affected 2.3.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-38rv-5jqc-m2cv
- recurly (PyPI) Vendor— Affected 2.2.0 to before 2.2.22 Fixed in 2.2.22 Patch available GHSA-38rv-5jqc-m2cv
- recurly (PyPI) Vendor— Affected 2.1.0 to before 2.1.16 Fixed in 2.1.16 Patch available GHSA-38rv-5jqc-m2cv
- recurly (PyPI) Vendor— Affected before 2.0.5 Fixed in 2.0.5 Patch available GHSA-38rv-5jqc-m2cv
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:recurly:recurly_client_python:*:*:*:*:*:*:*:* | 2.0.0 – 2.0.4; 2.1.0 – 2.1.15; 2.2.0 – 2.2.21 | Vulnerable | Recurly |
| cpe:2.3:a:recurly:recurly_client_python:2.3.0:*:*:*:*:*:*:* | 2.3.0 | Vulnerable | Recurly |
| cpe:2.3:a:recurly:recurly_client_python:*:*:*:*:*:*:*:* | 2.4.0 – 2.4.4 | Vulnerable | Recurly |
| cpe:2.3:a:recurly:recurly_client_python:2.5.0:*:*:*:*:*:*:* | 2.5.0 | Vulnerable | Recurly |
| cpe:2.3:a:recurly:recurly_client_python:2.6.0:*:*:*:*:*:*:* | 2.6.0 | Vulnerable | Recurly |
| cpe:2.3:a:recurly:recurly_client_python:2.6.1:*:*:*:*:*:*:* | 2.6.1 | Vulnerable | Recurly |
- cpe:2.3:a:recurly:recurly_client_python:*:*:*:*:*:*:*:* Versions 2.0.0 – 2.0.4; 2.1.0 – 2.1.15; 2.2.0 – 2.2.21 Vulnerable ·Recurly
- cpe:2.3:a:recurly:recurly_client_python:2.3.0:*:*:*:*:*:*:* Versions 2.3.0 Vulnerable ·Recurly
- cpe:2.3:a:recurly:recurly_client_python:*:*:*:*:*:*:*:* Versions 2.4.0 – 2.4.4 Vulnerable ·Recurly
- cpe:2.3:a:recurly:recurly_client_python:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Recurly
- cpe:2.3:a:recurly:recurly_client_python:2.6.0:*:*:*:*:*:*:* Versions 2.6.0 Vulnerable ·Recurly
- cpe:2.3:a:recurly:recurly_client_python:2.6.1:*:*:*:*:*:*:* Versions 2.6.1 Vulnerable ·Recurly
Remediation
- Fix · GHSA-38rv-5jqc-m2cv recurly (PyPI) Fixed in 2.6.2 Advisory →
- Fix · GHSA-38rv-5jqc-m2cv recurly (PyPI) Fixed in 2.5.1 Advisory →
- Fix · GHSA-38rv-5jqc-m2cv recurly (PyPI) Fixed in 2.4.5 Advisory →
- Fix · GHSA-38rv-5jqc-m2cv recurly (PyPI) Fixed in 2.3.1 Advisory →
- Fix · GHSA-38rv-5jqc-m2cv recurly (PyPI) Fixed in 2.2.22 Advisory →
- Fix · GHSA-38rv-5jqc-m2cv recurly (PyPI) Fixed in 2.1.16 Advisory →
- Fix · GHSA-38rv-5jqc-m2cv recurly (PyPI) Fixed in 2.0.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-0906
- 2026-10-03 Alias added: GHSA-38rv-5jqc-m2cv
References
Patch 1
Advisory 3
Sources
- CVE-2017-0906 · CVE Program
- CVE-2017-0906 · NVD
- FIRST EPSS
- GHSA-38rv-5jqc-m2cv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences