Read the docs
TI-2017-01579 Aliases CVE-2017-2298GHSA-3wcp-fjfh-pw9r

Improper input validation in Puppet mcollective

Priority LOW 32CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

The mcollective-sshkey-security plugin before 0.5.1 for Puppet uses a server-specified identifier as part of a path where a file is written. A compromised server could use this to write a file to an arbitrary location on the client with the filename appended with the string "_pub.pem".

Why it matters now

EPSS 0.01494 74th percentileScored 2026-11-07
Fix Fixed mcollective (Puppet): 0.5.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Puppetmcollectivebefore 0.5.10.5.1Patch availableCNA
  • mcollective VendorPuppet Affected before 0.5.1 Fixed in 0.5.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:puppet:mcollective-sshkey-security:*:*:*:*:*:puppet:*:*up to 0.5.0VulnerablePuppet
  • cpe:2.3:a:puppet:mcollective-sshkey-security:*:*:*:*:*:puppet:*:* Versions up to 0.5.0 Vulnerable ·Puppet

Remediation

  • Fix · CNA mcollective (Puppet) Fixed in 0.5.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-2298
  2. 2026-10-03 Alias added: GHSA-3wcp-fjfh-pw9r

References

Sources