Sensitive information in log files in python-oslo-middleware
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-532.
Summary
python-oslo-middleware before versions 3.8.1, 3.19.1, 3.23.1 is vulnerable to an information disclosure. Software using the CatchError class could include sensitive values in a traceback's error message. System users could exploit this flaw to obtain sensitive information from OpenStack component error logs (for example, keystone tokens).
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| unspecified | python-oslo-middleware | python-oslo-middleware 3.8.1; python-oslo-middleware 3.19.1; python-oslo-middleware 3.23.1 | — | No fix listed | CNA |
| — | oslo.middleware (PyPI) | 3.9.0 to before 3.19.1 | 3.19.1 | Patch available | GHSA-xcp8-hh74-f6mc |
| — | oslo.middleware (PyPI) | before 3.8.1 | 3.8.1 | Patch available | GHSA-xcp8-hh74-f6mc |
| — | oslo.middleware (PyPI) | 3.20.0 to before 3.23.1 | 3.23.1 | Patch available | GHSA-xcp8-hh74-f6mc |
| — | oslo-middleware (PyPI) | 3.9.0 to before 3.19.1 | 3.19.1 | Patch available | GHSA-xcp8-hh74-f6mc |
| — | oslo-middleware (PyPI) | before 3.8.1 | 3.8.1 | Patch available | GHSA-xcp8-hh74-f6mc |
| — | oslo-middleware (PyPI) | 3.20.0 to before 3.23.1 | 3.23.1 | Patch available | GHSA-xcp8-hh74-f6mc |
- python-oslo-middleware Vendorunspecified Affected python-oslo-middleware 3.8.1; python-oslo-middleware 3.19.1; python-oslo-middleware 3.23.1 Fixed in — No fix listed CNA
- oslo.middleware (PyPI) Vendor— Affected 3.9.0 to before 3.19.1 Fixed in 3.19.1 Patch available GHSA-xcp8-hh74-f6mc
- oslo.middleware (PyPI) Vendor— Affected before 3.8.1 Fixed in 3.8.1 Patch available GHSA-xcp8-hh74-f6mc
- oslo.middleware (PyPI) Vendor— Affected 3.20.0 to before 3.23.1 Fixed in 3.23.1 Patch available GHSA-xcp8-hh74-f6mc
- oslo-middleware (PyPI) Vendor— Affected 3.9.0 to before 3.19.1 Fixed in 3.19.1 Patch available GHSA-xcp8-hh74-f6mc
- oslo-middleware (PyPI) Vendor— Affected before 3.8.1 Fixed in 3.8.1 Patch available GHSA-xcp8-hh74-f6mc
- oslo-middleware (PyPI) Vendor— Affected 3.20.0 to before 3.23.1 Fixed in 3.23.1 Patch available GHSA-xcp8-hh74-f6mc
Remediation
- Fix · GHSA-xcp8-hh74-f6mc oslo.middleware (PyPI) Fixed in 3.19.1 Advisory →
- Fix · GHSA-xcp8-hh74-f6mc oslo.middleware (PyPI) Fixed in 3.8.1 Advisory →
- Fix · GHSA-xcp8-hh74-f6mc oslo.middleware (PyPI) Fixed in 3.23.1 Advisory →
- Fix · GHSA-xcp8-hh74-f6mc oslo-middleware (PyPI) Fixed in 3.19.1 Advisory →
- Fix · GHSA-xcp8-hh74-f6mc oslo-middleware (PyPI) Fixed in 3.8.1 Advisory →
- Fix · GHSA-xcp8-hh74-f6mc oslo-middleware (PyPI) Fixed in 3.23.1 Advisory →
Red Hat 2 advisories
- RHSA-2017:0435 Released 2017-03-02 · Red Hat rating Moderatepython-oslo-middleware security update
- Red Hat OpenStack Platform 9.0 python-oslo-middleware-3.7.0-2.el7ost, python-oslo-middleware-tests-3.7.0-2.el7ost
- RHSA-2017:0300 Released 2017-02-22 · Red Hat rating Moderatepython-oslo-middleware security update
- Red Hat OpenStack Platform 10.0 python-oslo-middleware-3.19.0-1.2.el7ost, python-oslo-middleware-lang-3.19.0-1.2.el7ost, python-oslo-middleware-tests-3.19.0-1.2.el7ost
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenStack Platform 10.0 | Fixed | RHSA-2017:0300 |
| Red Hat OpenStack Platform 9.0 | Fixed | RHSA-2017:0435 |
Not affected: 6 products
- Red Hat Enterprise Linux OpenStack Platform 5 (Icehouse)
- Red Hat Enterprise Linux OpenStack Platform 6 (Juno)
- Red Hat Enterprise Linux OpenStack Platform 7 (Kilo)
- Red Hat OpenStack Platform 11 (Ocata)
- Red Hat OpenStack Platform 8 (Liberty)
- Red Hat Storage 3
Timeline
- 2026-10-02 Threatist record created from CVE-2017-2592
- 2026-10-03 Alias added: GHSA-xcp8-hh74-f6mc
References
Patch 6
- https://review.openstack.org/#/c/425732/
- http://lists.openstack.org/pipermail/openstack-announce/2017-January/002002.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2592
- https://review.openstack.org/#/c/425730/
- https://review.openstack.org/#/c/425734/
- https://bugs.launchpad.net/keystonemiddleware/+bug/1628031
Advisory 7
Sources
- CVE-2017-2592 · CVE Program
- CVE-2017-2592 · NVD
- FIRST EPSS
- GHSA-xcp8-hh74-f6mc · GitHub Advisory Database · CC BY 4.0
- CVE-2017-2592 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences