Improper certificate validation in jenkins-ssh-slaves-plugin
Priority LOW 33CWE-295Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-295.
Summary
It was found that jenkins-ssh-slaves-plugin before version 1.15 did not perform host key verification, thereby enabling Man-in-the-Middle attacks.
Why it matters now
EPSS 0.01423 73rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:ssh-slaves (Maven): 1.15
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | jenkins-ssh-slaves-plugin | 1.15 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:ssh-slaves (Maven) | before 1.15 | 1.15 | Patch available | GHSA-x654-4wjh-74q6 |
- jenkins-ssh-slaves-plugin VendorJenkins Affected 1.15 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:ssh-slaves (Maven) Vendor— Affected before 1.15 Fixed in 1.15 Patch available GHSA-x654-4wjh-74q6
Remediation
- Fix · GHSA-x654-4wjh-74q6 org.jenkins-ci.plugins:ssh-slaves (Maven) Fixed in 1.15 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-2648
- 2026-10-03 Alias added: GHSA-x654-4wjh-74q6
References
Sources
- CVE-2017-2648 · CVE Program
- CVE-2017-2648 · NVD
- FIRST EPSS
- GHSA-x654-4wjh-74q6 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-2648 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences