Read the docs
TI-2017-02355 Aliases CVE-2017-3135GHSA-369c-w4jq-mxgx

Combination of DNS64 and RPZ Can Lead to Crash

Priority MEDIUM 50CWE-476Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.0 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-476.

Summary

Under some conditions when using both DNS64 and RPZ to rewrite query responses, query processing can resume in an inconsistent state leading to either an INSIST assertion failure or an attempt to read through a NULL pointer. Affects BIND 9.8.8, 9.9.3-S1 -> 9.9.9-S7, 9.9.3 -> 9.9.9-P5, 9.9.10b1, 9.10.0 -> 9.10.4-P5, 9.10.5b1, 9.11.0 -> 9.11.0-P2, 9.11.1b1.

Why it matters now

EPSS 0.17108 97th percentileScored 2026-11-07
Fix Fixed Red Hat: 1 advisory

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCBIND 9BIND 9 9.8.8, 9.9.3-S1 -> 9.9.9-S7, 9.9.3 -> 9.9.9-P5, 9.9.10b1, 9.10.0 -> 9.10.4-P5, 9.10.5b1, 9.11.0 -> 9.11.0-P2, 9.11.1b1—No fix listedCNA
  • BIND 9 VendorISC Affected BIND 9 9.8.8, 9.9.3-S1 -> 9.9.9-S7, 9.9.3 -> 9.9.9-P5, 9.9.10b1, 9.10.0 -> 9.10.4-P5, 9.10.5b1, 9.11.0 -> 9.11.0-P2, 9.11.1b1 Fixed in — No fix listed CNA

CPE configurations NVD · 33

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.9.3:*:*:*:*:*:*:*9.9.3VulnerableISC
cpe:2.3:a:isc:bind:9.9.3:s1:*:*:*:*:*:*9.9.3 s1VulnerableISC
cpe:2.3:a:isc:bind:9.9.8:*:*:*:*:*:*:*9.9.8VulnerableISC
cpe:2.3:a:isc:bind:9.9.9:p5:*:*:*:*:*:*9.9.9 p5VulnerableISC
cpe:2.3:a:isc:bind:9.9.9:s7:*:*:*:*:*:*9.9.9 s7VulnerableISC
cpe:2.3:a:isc:bind:9.9.10:beta1:*:*:*:*:*:*9.9.10 beta1VulnerableISC
cpe:2.3:a:isc:bind:9.10.0:*:*:*:*:*:*:*9.10.0VulnerableISC
cpe:2.3:a:isc:bind:9.10.4:p1:*:*:*:*:*:*9.10.4 p1VulnerableISC
cpe:2.3:a:isc:bind:9.10.4:p2:*:*:*:*:*:*9.10.4 p2VulnerableISC
cpe:2.3:a:isc:bind:9.10.4:p3:*:*:*:*:*:*9.10.4 p3VulnerableISC
  • cpe:2.3:a:isc:bind:9.9.3:*:*:*:*:*:*:* Versions 9.9.3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.3:s1:*:*:*:*:*:* Versions 9.9.3 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.8:*:*:*:*:*:*:* Versions 9.9.8 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.9:p5:*:*:*:*:*:* Versions 9.9.9 p5 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.9:s7:*:*:*:*:*:* Versions 9.9.9 s7 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.10:beta1:*:*:*:*:*:* Versions 9.9.10 beta1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.0:*:*:*:*:*:*:* Versions 9.10.0 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.4:p1:*:*:*:*:*:* Versions 9.10.4 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.4:p2:*:*:*:*:*:* Versions 9.10.4 p2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.4:p3:*:*:*:*:*:* Versions 9.10.4 p3 Vulnerable ·ISC
Show 23 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.10.4:p4:*:*:*:*:*:*9.10.4 p4VulnerableISC
cpe:2.3:a:isc:bind:9.10.4:p5:*:*:*:*:*:*9.10.4 p5VulnerableISC
cpe:2.3:a:isc:bind:9.10.5:beta1:*:*:*:*:*:*9.10.5 beta1VulnerableISC
cpe:2.3:a:isc:bind:9.11.0:*:*:*:*:*:*:*9.11.0VulnerableISC
cpe:2.3:a:isc:bind:9.11.0:p1:*:*:*:*:*:*9.11.0 p1VulnerableISC
cpe:2.3:a:isc:bind:9.11.0:p2:*:*:*:*:*:*9.11.0 p2VulnerableISC
cpe:2.3:a:isc:bind:9.11.1:beta1:*:*:*:*:*:*9.11.1 beta1VulnerableISC
cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:*7.0VulnerableRed Hat
cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:*7.0VulnerableRed Hat
cpe:2.3:o:redhat:enterprise_linux_server_aus:7.3:*:*:*:*:*:*:*7.3VulnerableRed Hat
cpe:2.3:o:redhat:enterprise_linux_server_aus:7.4:*:*:*:*:*:*:*7.4VulnerableRed Hat
cpe:2.3:o:redhat:enterprise_linux_server_aus:7.6:*:*:*:*:*:*:*7.6VulnerableRed Hat
cpe:2.3:o:redhat:enterprise_linux_server_eus:7.3:*:*:*:*:*:*:*7.3VulnerableRed Hat
cpe:2.3:o:redhat:enterprise_linux_server_eus:7.4:*:*:*:*:*:*:*7.4VulnerableRed Hat
cpe:2.3:o:redhat:enterprise_linux_server_eus:7.5:*:*:*:*:*:*:*7.5VulnerableRed Hat
cpe:2.3:o:redhat:enterprise_linux_server_eus:7.6:*:*:*:*:*:*:*7.6VulnerableRed Hat
cpe:2.3:o:redhat:enterprise_linux_server_tus:7.3:*:*:*:*:*:*:*7.3VulnerableRed Hat
cpe:2.3:o:redhat:enterprise_linux_server_tus:7.6:*:*:*:*:*:*:*7.6VulnerableRed Hat
cpe:2.3:o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:*:*7.0VulnerableRed Hat
cpe:2.3:a:netapp:data_ontap_edge:-:*:*:*:*:*:*:*not specified by NVDVulnerableNetApp
cpe:2.3:a:netapp:element_software_management_node:-:*:*:*:*:*:*:*not specified by NVDVulnerableNetApp
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
  • cpe:2.3:a:isc:bind:9.10.4:p4:*:*:*:*:*:* Versions 9.10.4 p4 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.4:p5:*:*:*:*:*:* Versions 9.10.4 p5 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.5:beta1:*:*:*:*:*:* Versions 9.10.5 beta1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.0:*:*:*:*:*:*:* Versions 9.11.0 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.0:p1:*:*:*:*:*:* Versions 9.11.0 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.0:p2:*:*:*:*:*:* Versions 9.11.0 p2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.1:beta1:*:*:*:*:*:* Versions 9.11.1 beta1 Vulnerable ·ISC
  • cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
  • cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
  • cpe:2.3:o:redhat:enterprise_linux_server_aus:7.3:*:*:*:*:*:*:* Versions 7.3 Vulnerable ·Red Hat
  • cpe:2.3:o:redhat:enterprise_linux_server_aus:7.4:*:*:*:*:*:*:* Versions 7.4 Vulnerable ·Red Hat
  • cpe:2.3:o:redhat:enterprise_linux_server_aus:7.6:*:*:*:*:*:*:* Versions 7.6 Vulnerable ·Red Hat
  • cpe:2.3:o:redhat:enterprise_linux_server_eus:7.3:*:*:*:*:*:*:* Versions 7.3 Vulnerable ·Red Hat
  • cpe:2.3:o:redhat:enterprise_linux_server_eus:7.4:*:*:*:*:*:*:* Versions 7.4 Vulnerable ·Red Hat
  • cpe:2.3:o:redhat:enterprise_linux_server_eus:7.5:*:*:*:*:*:*:* Versions 7.5 Vulnerable ·Red Hat
  • cpe:2.3:o:redhat:enterprise_linux_server_eus:7.6:*:*:*:*:*:*:* Versions 7.6 Vulnerable ·Red Hat
  • cpe:2.3:o:redhat:enterprise_linux_server_tus:7.3:*:*:*:*:*:*:* Versions 7.3 Vulnerable ·Red Hat
  • cpe:2.3:o:redhat:enterprise_linux_server_tus:7.6:*:*:*:*:*:*:* Versions 7.6 Vulnerable ·Red Hat
  • cpe:2.3:o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
  • cpe:2.3:a:netapp:data_ontap_edge:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
  • cpe:2.3:a:netapp:element_software_management_node:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian

Remediation

Red Hat 1 advisory

  • RHSA-2017:0276 Released 2017-02-15 · Red Hat rating Moderate
    bind security update
    • Red Hat Enterprise Linux Client (v. 7) bind-32:9.9.4-38.el7_3.2, bind-libs-32:9.9.4-38.el7_3.2, bind-libs-lite-32:9.9.4-38.el7_3.2 +2
    • Red Hat Enterprise Linux Client Optional (v. 7) bind-32:9.9.4-38.el7_3.2, bind-chroot-32:9.9.4-38.el7_3.2, bind-devel-32:9.9.4-38.el7_3.2 +7
    • Red Hat Enterprise Linux ComputeNode (v. 7) bind-32:9.9.4-38.el7_3.2, bind-libs-32:9.9.4-38.el7_3.2, bind-libs-lite-32:9.9.4-38.el7_3.2 +2
    • Red Hat Enterprise Linux ComputeNode Optional (v. 7) bind-32:9.9.4-38.el7_3.2, bind-chroot-32:9.9.4-38.el7_3.2, bind-devel-32:9.9.4-38.el7_3.2 +7
    • Red Hat Enterprise Linux Server (v. 7) bind-32:9.9.4-38.el7_3.2, bind-chroot-32:9.9.4-38.el7_3.2, bind-libs-32:9.9.4-38.el7_3.2 +8
    • Red Hat Enterprise Linux Server Optional (v. 7) bind-devel-32:9.9.4-38.el7_3.2, bind-devel-32:9.9.4-38.el7_3.2.ppc, bind-lite-devel-32:9.9.4-38.el7_3.2 +9
    • Red Hat Enterprise Linux Workstation (v. 7) bind-32:9.9.4-38.el7_3.2, bind-chroot-32:9.9.4-38.el7_3.2, bind-libs-32:9.9.4-38.el7_3.2 +6
    • Red Hat Enterprise Linux Workstation Optional (v. 7) bind-devel-32:9.9.4-38.el7_3.2, bind-lite-devel-32:9.9.4-38.el7_3.2, bind-pkcs11-devel-32:9.9.4-38.el7_3.2 +2

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux Client (v. 7)Fixed RHSA-2017:0276
Red Hat Enterprise Linux Client Optional (v. 7)Fixed RHSA-2017:0276
Red Hat Enterprise Linux ComputeNode (v. 7)Fixed RHSA-2017:0276
Red Hat Enterprise Linux ComputeNode Optional (v. 7)Fixed RHSA-2017:0276
Red Hat Enterprise Linux Server (v. 7)Fixed RHSA-2017:0276
Red Hat Enterprise Linux Server Optional (v. 7)Fixed RHSA-2017:0276
Red Hat Enterprise Linux Workstation (v. 7)Fixed RHSA-2017:0276
Red Hat Enterprise Linux Workstation Optional (v. 7)Fixed RHSA-2017:0276
Not affected: 2 products
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-3135
  2. 2026-10-03 Alias added: GHSA-369c-w4jq-mxgx

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources