Read the docs
TI-2017-02358 Aliases CVE-2017-3138GHSA-q858-q2j2-9jg4

named exits with a REQUIRE assertion failure if it receives a null command string on its control channel

Priority LOW 37CWE-617Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
No fix listed

Attack profile from CVSS 3.0 · CNA. Fix status from CNA. Impact type from CWE-617.

Summary

named contains a feature which allows operators to issue commands to a running server by communicating with the server process over a control channel, using a utility program such as rndc. A regression introduced in a recent feature change has created a situation under which some versions of named can be caused to exit with a REQUIRE assertion failure if they are sent a null command string. Affects BIND 9.9.9->9.9.9-P7, 9.9.10b1->9.9.10rc2, 9.10.4->9.10.4-P7, 9.10.5b1->9.10.5rc2, 9.11.0->9.11.0-P4, 9.11.1b1->9.11.1rc2, 9.9.9-S1->9.9.9-S9.

Why it matters now

EPSS 0.05503 92nd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCBIND 99.9.9->9.9.9-P7, 9.9.10b1->9.9.10rc2, 9.10.4->9.10.4-P7, 9.10.5b1->9.10.5rc2, 9.11.0->9.11.0-P4, 9.11.1b1->9.11.1rc2, 9.9.9-S1->9.9.9-S9—No fix listedCNA
  • BIND 9 VendorISC Affected 9.9.9->9.9.9-P7, 9.9.10b1->9.9.10rc2, 9.10.4->9.10.4-P7, 9.10.5b1->9.10.5rc2, 9.11.0->9.11.0-P4, 9.11.1b1->9.11.1rc2, 9.9.9-S1->9.9.9-S9 Fixed in — No fix listed CNA

CPE configurations NVD · 36

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.9.9:*:*:*:*:*:*:*9.9.9VulnerableISC
cpe:2.3:a:isc:bind:9.9.9:p1:*:*:*:*:*:*9.9.9 p1VulnerableISC
cpe:2.3:a:isc:bind:9.9.9:p2:*:*:*:*:*:*9.9.9 p2VulnerableISC
cpe:2.3:a:isc:bind:9.9.9:p3:*:*:*:*:*:*9.9.9 p3VulnerableISC
cpe:2.3:a:isc:bind:9.9.9:p4:*:*:*:*:*:*9.9.9 p4VulnerableISC
cpe:2.3:a:isc:bind:9.9.9:p5:*:*:*:*:*:*9.9.9 p5VulnerableISC
cpe:2.3:a:isc:bind:9.9.9:p6:*:*:*:*:*:*9.9.9 p6VulnerableISC
cpe:2.3:a:isc:bind:9.9.9:p7:*:*:*:*:*:*9.9.9 p7VulnerableISC
cpe:2.3:a:isc:bind:9.9.9:s1:*:*:*:*:*:*9.9.9 s1VulnerableISC
cpe:2.3:a:isc:bind:9.9.9:s7:*:*:*:*:*:*9.9.9 s7VulnerableISC
  • cpe:2.3:a:isc:bind:9.9.9:*:*:*:*:*:*:* Versions 9.9.9 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.9:p1:*:*:*:*:*:* Versions 9.9.9 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.9:p2:*:*:*:*:*:* Versions 9.9.9 p2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.9:p3:*:*:*:*:*:* Versions 9.9.9 p3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.9:p4:*:*:*:*:*:* Versions 9.9.9 p4 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.9:p5:*:*:*:*:*:* Versions 9.9.9 p5 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.9:p6:*:*:*:*:*:* Versions 9.9.9 p6 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.9:p7:*:*:*:*:*:* Versions 9.9.9 p7 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.9:s1:*:*:*:*:*:* Versions 9.9.9 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.9:s7:*:*:*:*:*:* Versions 9.9.9 s7 Vulnerable ·ISC
Show 26 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.9.10:beta1:*:*:*:*:*:*9.9.10 beta1VulnerableISC
cpe:2.3:a:isc:bind:9.9.10:rc1:*:*:*:*:*:*9.9.10 rc1VulnerableISC
cpe:2.3:a:isc:bind:9.9.10:rc2:*:*:*:*:*:*9.9.10 rc2VulnerableISC
cpe:2.3:a:isc:bind:9.10.4:*:*:*:*:*:*:*9.10.4VulnerableISC
cpe:2.3:a:isc:bind:9.10.4:p1:*:*:*:*:*:*9.10.4 p1VulnerableISC
cpe:2.3:a:isc:bind:9.10.4:p2:*:*:*:*:*:*9.10.4 p2VulnerableISC
cpe:2.3:a:isc:bind:9.10.4:p3:*:*:*:*:*:*9.10.4 p3VulnerableISC
cpe:2.3:a:isc:bind:9.10.4:p4:*:*:*:*:*:*9.10.4 p4VulnerableISC
cpe:2.3:a:isc:bind:9.10.4:p5:*:*:*:*:*:*9.10.4 p5VulnerableISC
cpe:2.3:a:isc:bind:9.10.4:p6:*:*:*:*:*:*9.10.4 p6VulnerableISC
cpe:2.3:a:isc:bind:9.10.4:p7:*:*:*:*:*:*9.10.4 p7VulnerableISC
cpe:2.3:a:isc:bind:9.10.5:b1:*:*:*:*:*:*9.10.5 b1VulnerableISC
cpe:2.3:a:isc:bind:9.10.5:rc1:*:*:*:*:*:*9.10.5 rc1VulnerableISC
cpe:2.3:a:isc:bind:9.10.5:rc2:*:*:*:*:*:*9.10.5 rc2VulnerableISC
cpe:2.3:a:isc:bind:9.11.0:*:*:*:*:*:*:*9.11.0VulnerableISC
cpe:2.3:a:isc:bind:9.11.0:p1:*:*:*:*:*:*9.11.0 p1VulnerableISC
cpe:2.3:a:isc:bind:9.11.0:p2:*:*:*:*:*:*9.11.0 p2VulnerableISC
cpe:2.3:a:isc:bind:9.11.0:p3:*:*:*:*:*:*9.11.0 p3VulnerableISC
cpe:2.3:a:isc:bind:9.11.0:p4:*:*:*:*:*:*9.11.0 p4VulnerableISC
cpe:2.3:a:isc:bind:9.11.1:b1:*:*:*:*:*:*9.11.1 b1VulnerableISC
cpe:2.3:a:isc:bind:9.11.1:rc1:*:*:*:*:*:*9.11.1 rc1VulnerableISC
cpe:2.3:a:isc:bind:9.11.1:rc2:*:*:*:*:*:*9.11.1 rc2VulnerableISC
cpe:2.3:a:netapp:data_ontap_edge:-:*:*:*:*:*:*:*not specified by NVDVulnerableNetApp
cpe:2.3:a:netapp:element_software:-:*:*:*:*:*:*:*not specified by NVDVulnerableNetApp
cpe:2.3:a:netapp:oncommand_balance:-:*:*:*:*:*:*:*not specified by NVDVulnerableNetApp
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
  • cpe:2.3:a:isc:bind:9.9.10:beta1:*:*:*:*:*:* Versions 9.9.10 beta1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.10:rc1:*:*:*:*:*:* Versions 9.9.10 rc1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.10:rc2:*:*:*:*:*:* Versions 9.9.10 rc2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.4:*:*:*:*:*:*:* Versions 9.10.4 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.4:p1:*:*:*:*:*:* Versions 9.10.4 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.4:p2:*:*:*:*:*:* Versions 9.10.4 p2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.4:p3:*:*:*:*:*:* Versions 9.10.4 p3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.4:p4:*:*:*:*:*:* Versions 9.10.4 p4 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.4:p5:*:*:*:*:*:* Versions 9.10.4 p5 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.4:p6:*:*:*:*:*:* Versions 9.10.4 p6 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.4:p7:*:*:*:*:*:* Versions 9.10.4 p7 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.5:b1:*:*:*:*:*:* Versions 9.10.5 b1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.5:rc1:*:*:*:*:*:* Versions 9.10.5 rc1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.5:rc2:*:*:*:*:*:* Versions 9.10.5 rc2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.0:*:*:*:*:*:*:* Versions 9.11.0 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.0:p1:*:*:*:*:*:* Versions 9.11.0 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.0:p2:*:*:*:*:*:* Versions 9.11.0 p2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.0:p3:*:*:*:*:*:* Versions 9.11.0 p3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.0:p4:*:*:*:*:*:* Versions 9.11.0 p4 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.1:b1:*:*:*:*:*:* Versions 9.11.1 b1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.1:rc1:*:*:*:*:*:* Versions 9.11.1 rc1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.1:rc2:*:*:*:*:*:* Versions 9.11.1 rc2 Vulnerable ·ISC
  • cpe:2.3:a:netapp:data_ontap_edge:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
  • cpe:2.3:a:netapp:element_software:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
  • cpe:2.3:a:netapp:oncommand_balance:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian

Remediation

No fixed version listed by the sources yet.

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    ISC BIND 9 — DSA-3854

    3 records Highest priority Priority MEDIUM 2 MEDIUM, 1 LOW

    Other records, highest priority first

    • TI-2017-02357 A response packet can cause a resolver to terminate when processing an answer containing a CNAME or DNAMEPriority MEDIUM 44
    • TI-2017-02356 An error handling synthesized records could cause an assertion failure when using DNS64 with "break-dnssec yes;"Priority MEDIUM 40

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 3 products
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-3138
  2. 2026-10-03 Alias added: GHSA-q858-q2j2-9jg4

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources